summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xcave
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xcave')
-rw-r--r--x11-misc/xcave/Manifest2
-rw-r--r--x11-misc/xcave/metadata.xml5
-rw-r--r--x11-misc/xcave/xcave-2.3.2.ebuild35
-rw-r--r--x11-misc/xcave/xcave-2.4.0.ebuild28
4 files changed, 70 insertions, 0 deletions
diff --git a/x11-misc/xcave/Manifest b/x11-misc/xcave/Manifest
new file mode 100644
index 000000000000..0c9e3a5e9403
--- /dev/null
+++ b/x11-misc/xcave/Manifest
@@ -0,0 +1,2 @@
+DIST xcave-2.3.2.tar.gz 817887 SHA256 d80376f56c2fa62f61f55ce50dcf0e65032c78e9319e6e411fbd6d3f01887ac3 SHA512 3948bfd62deb9c29eb333093a7295ec8a2ee5633bed881252351bc3355803893e15ccd0145189a7d6a6160c89617b757c9b3205037a015f1da881160fd480f96 WHIRLPOOL 25c014b01aa84cc2e14b6b45e457c58134a35ef9bc666549e9f6739692213cf165090d686b2db3894c95c525216323d56e80971a1a1b617dba034b2862276881
+DIST xcave-2.4.0.tar.gz 817356 SHA256 e561850fe4fc4c7ac5ea592dd43590a4049cd2cc52595333ba953d660d9dc533 SHA512 cdba5ad8b7634004a9439fd87a8eb8ed45137e78cb119310c6b7df9352aa979682edaae6440200804e23953c822d377c95cf459cc37ce227d1a41885a91afba4 WHIRLPOOL e9c4b6469adc7a6183cd431efa86ead19fd246a408b23fa84135942532531635ad9be6136145578963720944f8895d672e9b4625933e900333c75d15b56f3136
diff --git a/x11-misc/xcave/metadata.xml b/x11-misc/xcave/metadata.xml
new file mode 100644
index 000000000000..540f810e069d
--- /dev/null
+++ b/x11-misc/xcave/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>
diff --git a/x11-misc/xcave/xcave-2.3.2.ebuild b/x11-misc/xcave/xcave-2.3.2.ebuild
new file mode 100644
index 000000000000..748ddbd3909c
--- /dev/null
+++ b/x11-misc/xcave/xcave-2.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools
+
+DESCRIPTION="View and manage contents of your wine cellar"
+HOMEPAGE="http://xcave.free.fr/index-en.php"
+SRC_URI="http://${PN}.free.fr/backbone.php?what=download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.8:2
+ >=gnome-base/libglade-2.6
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext
+ dev-util/intltool"
+
+src_prepare() {
+ echo src/xcave_supp.c > po/POTFILES.skip
+# intltoolize --force --copy --automake || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog TODO
+ rm -rf "${D}"/usr/doc
+}
diff --git a/x11-misc/xcave/xcave-2.4.0.ebuild b/x11-misc/xcave/xcave-2.4.0.ebuild
new file mode 100644
index 000000000000..246953daed92
--- /dev/null
+++ b/x11-misc/xcave/xcave-2.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="View and manage contents of your wine cellar"
+HOMEPAGE="http://xcave.free.fr/index-en.php"
+SRC_URI="http://${PN}.free.fr/backbone.php?what=download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND=">=x11-libs/gtk+-2.8:2
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/gettext
+ dev-util/intltool"
+
+src_install() {
+ default
+ dodoc ChangeLog TODO
+ rm -rfv "${D}"/usr/doc
+}