summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2023-08-31 10:14:11 +0200
committerAgostino Sarubbo <ago@gentoo.org>2023-08-31 10:14:11 +0200
commit2205e59ae0564a7db2db7b0ea20e7f093bfcfe5a (patch)
tree17c6d9fa5469f340aad35065007a1ca604081737 /x11-misc
parentdev-lang/spidermonkey: remove broken mold dep #908472 (diff)
downloadgentoo-2205e59ae0564a7db2db7b0ea20e7f093bfcfe5a.tar.gz
gentoo-2205e59ae0564a7db2db7b0ea20e7f093bfcfe5a.tar.bz2
gentoo-2205e59ae0564a7db2db7b0ea20e7f093bfcfe5a.zip
x11-misc/birdtray: bump to 1.11.2 - EAPI 8 - sync 9999 ebuild
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/birdtray/Manifest1
-rw-r--r--x11-misc/birdtray/birdtray-1.11.2.ebuild43
-rw-r--r--x11-misc/birdtray/birdtray-9999.ebuild9
3 files changed, 50 insertions, 3 deletions
diff --git a/x11-misc/birdtray/Manifest b/x11-misc/birdtray/Manifest
index 627878d6b052..54cc70aceede 100644
--- a/x11-misc/birdtray/Manifest
+++ b/x11-misc/birdtray/Manifest
@@ -1 +1,2 @@
+DIST birdtray-1.11.2.gh.tar.gz 871363 BLAKE2B 6043fa16ebf6675f0ca4d26d0d35432d6cea88f412f4ea74b9dec329d2aaf728de1c25507d068126113eb287bf0693530e6967e1087bcc39efcc62aef7c2f703 SHA512 84d69c940fef4b23f78ea4c5dbdbde4698eafe56785c82458a95dfc282e06c77c4a68dfc553ac4198ac87eedbe5354a2b2f80e72542a019dcc514d4142160e5b
DIST birdtray-1.9.0.tar.gz 810297 BLAKE2B acc6593116fa735311f62405406192ad43e8af6481eac1d09298f846f5fab9a0dff575caefe9490d0a183c464fab763515e20e5725649fe4a800e575f712067b SHA512 898bfcebc7ba4b738e3ab41539c4de48871ebccf431bb1b12464e7f2956bad95af6158742c64ec5923d63889e777c98c75db31121d926e26f3dfe1b34d9f8b4a
diff --git a/x11-misc/birdtray/birdtray-1.11.2.ebuild b/x11-misc/birdtray/birdtray-1.11.2.ebuild
new file mode 100644
index 000000000000..82afb728b6df
--- /dev/null
+++ b/x11-misc/birdtray/birdtray-1.11.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="A new mail system tray notification icon for Thunderbird"
+HOMEPAGE="https://github.com/gyunaev/birdtray"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/gyunaev/birdtray.git"
+else
+ SRC_URI="https://github.com/gyunaev/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="dev-db/sqlite:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11"
+
+DEPEND="${RDEPEND}"
+
+# https://github.com/gyunaev/birdtray/commit/74a97df3a17efd5ef679b8eed6999b97abc23f10
+# translations have been made optional, let's see how we would manage them
+BDEPEND="dev-qt/linguist-tools:5"
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/x11-misc/birdtray/birdtray-9999.ebuild b/x11-misc/birdtray/birdtray-9999.ebuild
index 4fb71861085b..82afb728b6df 100644
--- a/x11-misc/birdtray/birdtray-9999.ebuild
+++ b/x11-misc/birdtray/birdtray-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake xdg-utils
@@ -12,7 +12,7 @@ if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/gyunaev/birdtray.git"
else
- SRC_URI="https://github.com/gyunaev/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/gyunaev/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
KEYWORDS="~amd64"
fi
@@ -29,6 +29,9 @@ RDEPEND="dev-db/sqlite:=
x11-libs/libX11"
DEPEND="${RDEPEND}"
+
+# https://github.com/gyunaev/birdtray/commit/74a97df3a17efd5ef679b8eed6999b97abc23f10
+# translations have been made optional, let's see how we would manage them
BDEPEND="dev-qt/linguist-tools:5"
pkg_postinst() {