summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-01-08 15:08:49 -0500
committerMatt Turner <mattst88@gentoo.org>2024-01-08 15:09:30 -0500
commit7e044c032249551ca05f1a47d8f1e7499f45e971 (patch)
tree67e449225d32cdbc7fa56924af33cde8c9a4e357 /x11-misc
parentkde-plasma/plasma-desktop: Add missing BDEPEND (diff)
downloadgentoo-7e044c032249551ca05f1a47d8f1e7499f45e971.tar.gz
gentoo-7e044c032249551ca05f1a47d8f1e7499f45e971.tar.bz2
gentoo-7e044c032249551ca05f1a47d8f1e7499f45e971.zip
x11-misc/imake: Version bump to 1.0.10
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/imake/Manifest1
-rw-r--r--x11-misc/imake/imake-1.0.10.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/x11-misc/imake/Manifest b/x11-misc/imake/Manifest
index bb0f43c35a82..697c20d92f69 100644
--- a/x11-misc/imake/Manifest
+++ b/x11-misc/imake/Manifest
@@ -1 +1,2 @@
+DIST imake-1.0.10.tar.xz 155284 BLAKE2B 85ea5d14280b0e4e3d07f806b1ebc777f1c6f431af05e94571e1d7908028f1497c4b5edb6e808c858429e98f314fe6c3cee84e265a30fce02d7ebeaa2111ab8d SHA512 ea96db27a6da13ea2d64652936e508b5e3d5d712347a2eb248376dc1f262c18720d9934b8ae69b4c0fc65b135c847be42da084fe924e4825ce1d359f4ef7e60f
DIST imake-1.0.9.tar.xz 153332 BLAKE2B d9de997016112833e50d1151448366c538b9796622630724552cc0476deed165621edc1a01318a83b577a85fcfc78b753e6fa9fbdf4c71413319abe542f1beca SHA512 e7587cf80369c8f4fcc1207c13bcb74a53d838b504ac8a7f3b98fb8f5f595cc7b8e5e9fad50cadcf40cf27bd02ef4eae7fe458854bbed7bea27d474d66520644
diff --git a/x11-misc/imake/imake-1.0.10.ebuild b/x11-misc/imake/imake-1.0.10.ebuild
new file mode 100644
index 000000000000..db1832b81b79
--- /dev/null
+++ b/x11-misc/imake/imake-1.0.10.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+XORG_TARBALL_SUFFIX="xz"
+inherit toolchain-funcs xorg-3
+
+DESCRIPTION="C preprocessor interface to the make utility"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="x11-misc/xorg-cf-files"
+DEPEND="x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.8-cpp-args.patch
+ "${FILESDIR}"/${PN}-1.0.9-no-get-gcc.patch
+ "${FILESDIR}"/${PN}-1.0.8-respect-LD.patch
+ "${FILESDIR}"/${PN}-1.0.8-xmkmf-pass-cc-ld.patch
+)
+
+src_configure() {
+ econf CPP="$(tc-getPROG CPP cpp)" #722046
+}