summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-02-14 09:07:18 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2022-02-14 09:07:29 +0100
commite05387344d443bb179eb3b1e7cc00dd161cd31e0 (patch)
tree33ce1301d72bd81b4fef68874d2b2e6683cd0f3a /x11-misc
parentdev-libs/libowfat: x86 stable wrt bug #833201 (diff)
downloadgentoo-e05387344d443bb179eb3b1e7cc00dd161cd31e0.tar.gz
gentoo-e05387344d443bb179eb3b1e7cc00dd161cd31e0.tar.bz2
gentoo-e05387344d443bb179eb3b1e7cc00dd161cd31e0.zip
x11-misc/picom: 9.1 bump
Closes: https://bugs.gentoo.org/833286 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/picom/Manifest1
-rw-r--r--x11-misc/picom/picom-9.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/x11-misc/picom/Manifest b/x11-misc/picom/Manifest
index 14107405285e..9007b171700f 100644
--- a/x11-misc/picom/Manifest
+++ b/x11-misc/picom/Manifest
@@ -1 +1,2 @@
DIST picom-8.2.tar.gz 242653 BLAKE2B 1c76ad4b3152d47155f957f8f1e75447ec8e30d05bc5fb9bf09c890552168cc3c607c8980b262b18cd5f3dc2654a3416cad20cb7fe829eaef8380783d1847c82 SHA512 bdc6675e73a211075ee0df2b056342cabb19ad27fd73586f5216886f503cd994536845eb866f371e07a8dc0404346c67b899a14830e9b7cbc9c01cbd782f36b1
+DIST picom-9.1.tar.gz 263924 BLAKE2B 093f2fe12f3388b7979379d2e2b695a779cc9ebf95cbfa5b4f39c4fcc7cd6fc82be662bb9b0355fbadca66c0b0d7ac0d1e463272b0dbe4bbcca985691b6255e9 SHA512 375dc245be1c0f277bc0ddfc6e6480255efba06ce49f953c5314b7ba9795d1f50c5de907762208becc13c5210f24ac5b2241e2eb5e0e10dc5e5b96081cc821df
diff --git a/x11-misc/picom/picom-9.1.ebuild b/x11-misc/picom/picom-9.1.ebuild
new file mode 100644
index 000000000000..c26adc87f474
--- /dev/null
+++ b/x11-misc/picom/picom-9.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit meson python-any-r1 virtualx xdg
+
+DESCRIPTION="A lightweight compositor for X11 (previously a compton fork)"
+HOMEPAGE="https://github.com/yshui/picom"
+SRC_URI="https://github.com/yshui/picom/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+config-file dbus +doc +drm opengl pcre test"
+
+REQUIRED_USE="test? ( dbus )" # avoid "DBus support not compiled in!"
+RESTRICT="test" # but tests require dbus_next
+
+RDEPEND="dev-libs/libev
+ dev-libs/uthash
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXext
+ x11-libs/pixman
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-renderutil
+ config-file? (
+ dev-libs/libconfig:=
+ )
+ dbus? ( sys-apps/dbus )
+ drm? ( x11-libs/libdrm )
+ opengl? ( virtual/opengl )
+ pcre? ( dev-libs/libpcre )
+ !x11-misc/compton"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig
+ doc? ( app-text/asciidoc )
+ test? ( $(python_gen_any_dep 'dev-python/xcffib[${PYTHON_USEDEP}]') )
+"
+
+DOCS=( README.md picom.sample.conf )
+
+python_check_deps() {
+ has_version -b "dev-python/xcffib[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use config-file config_file)
+ $(meson_use dbus)
+ $(meson_use doc with_docs)
+ $(meson_use opengl)
+ $(meson_use pcre regex)
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ virtx "${S}/tests/run_tests.sh" "${BUILD_DIR}/src/${PN}"
+}