summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-04-04 14:47:06 +0200
committerSam James <sam@gentoo.org>2022-04-21 20:54:40 +0100
commit228f28b254c1e95bf96e37038d0ab17c5968576e (patch)
treee50f22912ba26b7ba96b3c79702b159b4223c597 /x11-plugins/gkrellm-volume
parentx11-plugins/gkrellm-imonc: update EAPI 6 -> 8 (diff)
downloadgentoo-228f28b254c1e95bf96e37038d0ab17c5968576e.tar.gz
gentoo-228f28b254c1e95bf96e37038d0ab17c5968576e.tar.bz2
gentoo-228f28b254c1e95bf96e37038d0ab17c5968576e.zip
x11-plugins/gkrellm-volume: update EAPI 6 -> 8
Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins/gkrellm-volume')
-rw-r--r--x11-plugins/gkrellm-volume/files/gkrellm-volume-2.1.13-r3-pkgconfig.patch27
-rw-r--r--x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r3.ebuild38
2 files changed, 65 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-volume/files/gkrellm-volume-2.1.13-r3-pkgconfig.patch b/x11-plugins/gkrellm-volume/files/gkrellm-volume-2.1.13-r3-pkgconfig.patch
new file mode 100644
index 000000000000..75defc76a9d0
--- /dev/null
+++ b/x11-plugins/gkrellm-volume/files/gkrellm-volume-2.1.13-r3-pkgconfig.patch
@@ -0,0 +1,27 @@
+Respect user's pkg-config
+--- a/Makefile
++++ b/Makefile
+@@ -6,13 +6,13 @@ LOCALEDIR ?= /usr/local/share/locale
+ CFLAGS += -DPACKAGE="\"$(PACKAGE)\""
+ export PACKAGE LOCALEDIR
+
+-GTK_CONFIG = pkg-config gtk+-2.0
++PKG_CONFIG ?= pkg-config
+
+ PLUGIN_DIR ?= /usr/local/lib/gkrellm2/plugins
+ GKRELLM_INCLUDE = -I/usr/local/include
+
+-GTK_CFLAGS = `$(GTK_CONFIG) --cflags`
+-GTK_LIB = `$(GTK_CONFIG) --libs`
++GTK_CFLAGS = $(shell ${PKG_CONFIG} gtk+-2.0 --cflags)
++GTK_LIB = $(shell ${PKG_CONFIG} gtk+-2.0 --libs)
+
+ CFLAGS := $(CFLAGS) -fPIC $(GTK_CFLAGS) $(GKRELLM_INCLUDE)
+ LIBS = $(GTK_LIB)
+@@ -51,4 +51,4 @@ install:
+ (cd po && ${MAKE} install)
+ $(INSTALL_PROGRAM) volume.so $(PLUGIN_DIR)
+
+-%.c.o: %.c
+\ No newline at end of file
++%.c.o: %.c
diff --git a/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r3.ebuild b/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r3.ebuild
new file mode 100644
index 000000000000..b3affa03f88b
--- /dev/null
+++ b/x11-plugins/gkrellm-volume/gkrellm-volume-2.1.13-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="A mixer control plugin for gkrellm"
+HOMEPAGE="http://gkrellm.luon.net/volume.php"
+SRC_URI="http://gkrellm.luon.net/files/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="alsa"
+
+RDEPEND="
+ app-admin/gkrellm:2[X]
+ alsa? ( media-libs/alsa-lib )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-reenable.patch"
+ "${FILESDIR}/${P}-makefile.patch"
+ "${FILESDIR}/${P}-r3-pkgconfig.patch"
+)
+
+src_configure() {
+ PLUGIN_SO=( volume$(get_modname) )
+ default
+}
+
+src_compile() {
+ tc-export PKG_CONFIG
+ use alsa && local myconf="enable_alsa=1"
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" ${myconf}
+}