summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmcalendar
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmcalendar')
-rw-r--r--x11-plugins/wmcalendar/Manifest1
-rw-r--r--x11-plugins/wmcalendar/files/wmcalendar-0.5.2-exit-sin-and-cos.patch67
-rw-r--r--x11-plugins/wmcalendar/files/wmcalendar-0.5.2-ical.patch19
-rw-r--r--x11-plugins/wmcalendar/files/wmcalendar-0.5.2-rename_kill_func.patch20
-rw-r--r--x11-plugins/wmcalendar/metadata.xml8
-rw-r--r--x11-plugins/wmcalendar/wmcalendar-0.5.2-r1.ebuild38
-rw-r--r--x11-plugins/wmcalendar/wmcalendar-0.5.2.ebuild41
7 files changed, 194 insertions, 0 deletions
diff --git a/x11-plugins/wmcalendar/Manifest b/x11-plugins/wmcalendar/Manifest
new file mode 100644
index 000000000000..7807759bc740
--- /dev/null
+++ b/x11-plugins/wmcalendar/Manifest
@@ -0,0 +1 @@
+DIST wmcalendar-0.5.2.tar.gz 42720 SHA256 1915fe5b9af9de400650db4e9e4fa5934115902e8906144bf266b2f3503e0c00 SHA512 8d60a46f26657bf4876057ed092440018055e5a1ab6e2811a9c27f351533bfe6c941dbec10880daafe0858766cb890863cb66bfb70412e025a8d59ab96c663d7 WHIRLPOOL 416726d0c568aa7246e04dc567457928a2af71c371dad519504982f2f9ef3dbed57f2478d927e9c6f869f2823a13386e28fd124b8839fb9426d83f19b07f5ee4
diff --git a/x11-plugins/wmcalendar/files/wmcalendar-0.5.2-exit-sin-and-cos.patch b/x11-plugins/wmcalendar/files/wmcalendar-0.5.2-exit-sin-and-cos.patch
new file mode 100644
index 000000000000..1f51b17889ed
--- /dev/null
+++ b/x11-plugins/wmcalendar/files/wmcalendar-0.5.2-exit-sin-and-cos.patch
@@ -0,0 +1,67 @@
+--- a/Src/calendarfunc.c 2003-07-13 17:41:02.000000000 +0300
++++ b/Src/calendarfunc.c 2008-05-03 10:03:06.000000000 +0300
+@@ -22,7 +22,7 @@
+
+ #include "calendarfunc.h"
+ #include <stdio.h>
+-
++#include <math.h>
+
+
+ long persian_jdn(struct icaltimetype dt)
+--- a/Src/dockapp.c 2003-07-15 18:15:12.000000000 +0300
++++ b/Src/dockapp.c 2008-05-03 10:03:34.000000000 +0300
+@@ -23,6 +23,7 @@
+ * modified by Seiichi SATO <ssato@sh.rim.or.jp>
+ */
+
++#include <stdlib.h>
+ #include "dockapp.h"
+
+ #define WINDOWED_SIZE_W 64
+--- a/Src/Makefile 2003-07-15 18:19:26.000000000 +0300
++++ b/Src/Makefile 2008-05-03 10:11:48.000000000 +0300
+@@ -1,19 +1,15 @@
+-CC = gcc
++CC ?= gcc
+ INCLUDES = `pkg-config --cflags gtk+-2.0` -I.
+-LFLAGS = `pkg-config --libs gtk+-2.0`
+
+ # for BSD
+ #INCLUDES = `gtk12-config --cflags` -I.
+ #LFLAGS = `gtk12-config --libs`
+-X11BASE = /usr/X11R6
+-CFLAGS = $(INCLUDES) -DICON_TYPE=$(ICON_TYPE)
+-INCDIR = -I$(X11BASE)/include/X11 -I$(X11BASE)/include -I$/usr/include -I$/usr/local/include
+-DESTDIR= /usr/local
+-LIBDIR = -L/usr/lib -L${X11BASE}/lib -L/usr/local/lib
++CFLAGS += $(INCLUDES) -DICON_TYPE=$(ICON_TYPE)
++PREFIX = /usr
+ PACKAGE = wmCalendar
+
+ # for Linux
+-LIBS = $(LIBDIR) -lXpm -lical -lpthread
++LIBS = -lpthread -lm $(shell $(PKG_CONFIG) --libs gtk+-2.0 x11 xpm xext libical)
+ # for Solaris (untested!!!)
+ # LIBS = -lXpm -lX11 -lXext -lsocket -lnsl -lical
+
+@@ -30,7 +26,7 @@
+ all: wmCalendar.o wmCalendar
+
+ wmCalendar: $(OBJECTS)
+- $(CC) $(COPTS) $(SYSTEM) $(LFLAGS) -o $@ $(OBJECTS) -o wmCalendar $(INCDIR)$(LIBDIR) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJECTS) $(LIBS) -o $@
+
+ wmCalendar.o: wmCalendar_master.xpm wmCalendar_master2.xpm
+ clean:
+@@ -40,6 +36,8 @@
+ rm -f wmCalendar
+
+ install:: wmCalendar
+- install -c -s -m 0755 wmCalendar $(DESTDIR)/bin/
+- install -c -m 0644 wmCalendar.1 $(DESTDIR)/man/man1
++ install -d $(DESTDIR)$(PREFIX)/bin
++ install -m 0755 wmCalendar $(DESTDIR)$(PREFIX)/bin
++ install -d $(DESTDIR)$(PREFIX)/share/man/man1
++ install -m 0644 wmCalendar.1 $(DESTDIR)$(PREFIX)/share/man/man1
+
diff --git a/x11-plugins/wmcalendar/files/wmcalendar-0.5.2-ical.patch b/x11-plugins/wmcalendar/files/wmcalendar-0.5.2-ical.patch
new file mode 100644
index 000000000000..76a92a65b1db
--- /dev/null
+++ b/x11-plugins/wmcalendar/files/wmcalendar-0.5.2-ical.patch
@@ -0,0 +1,19 @@
+--- a/Src/calendar.h
++++ b/Src/calendar.h
+@@ -1,4 +1,4 @@
+-#include <ical.h>
++#include <libical/ical.h>
+ #include <stdlib.h>
+ #include <gtk/gtk.h>
+ #include <string.h>
+--- a/Src/calendarfunc.h
++++ b/Src/calendarfunc.h
+@@ -22,7 +22,7 @@
+
+ #include <unistd.h>
+ #include <stdlib.h>
+-#include <ical.h>
++#include <libical/ical.h>
+ #define TIMZ 3.0
+ #define MINAGE 13.5
+ #define SUNSET 19.5 /*approximate */
diff --git a/x11-plugins/wmcalendar/files/wmcalendar-0.5.2-rename_kill_func.patch b/x11-plugins/wmcalendar/files/wmcalendar-0.5.2-rename_kill_func.patch
new file mode 100644
index 000000000000..fc648a6b60d0
--- /dev/null
+++ b/x11-plugins/wmcalendar/files/wmcalendar-0.5.2-rename_kill_func.patch
@@ -0,0 +1,20 @@
+--- a/Src/calendar.c
++++ b/Src/calendar.c
+@@ -48,7 +48,7 @@
+
+
+
+-void kill (GtkWidget * widget)
++void close_app (GtkWidget * widget)
+ {
+ gtk_widget_destroy ((GtkWidget*)gtk_widget_get_toplevel(widget));
+ gtk_main_quit ();
+@@ -193,7 +193,7 @@
+ gtk_signal_connect(GTK_OBJECT (event_box), "button_press_event",
+ GTK_SIGNAL_FUNC (move), NULL);
+ gtk_signal_connect(GTK_OBJECT (event_box2), "button_press_event",
+- (GtkSignalFunc) kill, GTK_OBJECT(dayView));
++ (GtkSignalFunc) close_app, GTK_OBJECT(dayView));
+
+ gtk_widget_realize(dayView);
+ // gtk_window_set_position(GTK_WINDOW (dayView),GTK_WIN_POS_CENTER_ON_PARENT);
diff --git a/x11-plugins/wmcalendar/metadata.xml b/x11-plugins/wmcalendar/metadata.xml
new file mode 100644
index 000000000000..53b9ac4c72bf
--- /dev/null
+++ b/x11-plugins/wmcalendar/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+ <upstream>
+ <remote-id type="sourceforge">wmcalendar</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/wmcalendar/wmcalendar-0.5.2-r1.ebuild b/x11-plugins/wmcalendar/wmcalendar-0.5.2-r1.ebuild
new file mode 100644
index 000000000000..0a0b3818c65d
--- /dev/null
+++ b/x11-plugins/wmcalendar/wmcalendar-0.5.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="a calendar dockapp"
+HOMEPAGE="http://wmcalendar.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libical
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( ../{BUGS,CHANGES,HINTS,README,TODO} )
+
+S=${WORKDIR}/${P}/Src
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-exit-sin-and-cos.patch
+ epatch "${FILESDIR}"/${P}-rename_kill_func.patch
+ epatch "${FILESDIR}"/${P}-ical.patch
+ tc-export CC PKG_CONFIG
+}
diff --git a/x11-plugins/wmcalendar/wmcalendar-0.5.2.ebuild b/x11-plugins/wmcalendar/wmcalendar-0.5.2.ebuild
new file mode 100644
index 000000000000..05cf58370e23
--- /dev/null
+++ b/x11-plugins/wmcalendar/wmcalendar-0.5.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="a calendar dockapp"
+HOMEPAGE="http://wmcalendar.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="dev-libs/libical
+ x11-libs/gtk+:2
+ x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${P}/Src
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-exit-sin-and-cos.patch \
+ "${FILESDIR}"/${P}-rename_kill_func.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ../{BUGS,CHANGES,HINTS,README,TODO}
+}