summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-02-19 23:03:26 +0100
committerDavid Seifert <soap@gentoo.org>2023-02-19 23:03:26 +0100
commitbcf151bd9c3cbd3d78b10059d99de2c927b19e2c (patch)
tree7e0d5bdb5bad9e7af5884ac8558dbeb0098d9a34 /x11-terms/yeahconsole
parentgames-fps/freedm-data: enable py3.11 (diff)
downloadgentoo-bcf151bd9c3cbd3d78b10059d99de2c927b19e2c.tar.gz
gentoo-bcf151bd9c3cbd3d78b10059d99de2c927b19e2c.tar.bz2
gentoo-bcf151bd9c3cbd3d78b10059d99de2c927b19e2c.zip
x11-terms/yeahconsole: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-terms/yeahconsole')
-rw-r--r--x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch45
-rw-r--r--x11-terms/yeahconsole/yeahconsole-0.3.4-r2.ebuild (renamed from x11-terms/yeahconsole/yeahconsole-0.3.4-r1.ebuild)30
2 files changed, 39 insertions, 36 deletions
diff --git a/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch b/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch
index 0075c433292b..e7f6b154efd4 100644
--- a/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch
+++ b/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch
@@ -1,30 +1,41 @@
---- a/Makefile 2006-01-14 16:54:05.000000000 +0100
-+++ b/Makefile 2009-02-26 16:18:25.000000000 +0100
-@@ -1,6 +1,4 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,30 +1,21 @@
TARGET = yeahconsole
-CC = gcc
-#CC = cc
INSTALL = install
- PREFIX = /usr/local
-@@ -8,17 +6,16 @@
- LIBS = -lX11
- INCLUDES = -I/usr/X11R6/include
- LIB_DIRS = -L/usr/X11R6/lib
--FLAGS = -Os -Wall
-+FLAGS = -Wall $(CFLAGS)
-
- OBJECTS := yeahconsole.o
- SOURCES := yeahconsole.c
+-PREFIX = /usr/local
++PREFIX = $(EPREFIX)/usr
- $(TARGET): $(OBJECTS)
+-LIBS = -lX11
+-INCLUDES = -I/usr/X11R6/include
+-LIB_DIRS = -L/usr/X11R6/lib
+-FLAGS = -Os -Wall
+-
+-OBJECTS := yeahconsole.o
+-SOURCES := yeahconsole.c
+-
+-$(TARGET): $(OBJECTS)
- $(CC) $(DEFINES) $(INCLUDES) $(LIB_DIRS) $(LIBS) -o $@ $<
- strip $@
-+ $(CC) $(FLAGS) $(LDFLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -o $@ $< $(LIBS)
++PKG_CONFIG ?= lol
++CFLAGS += -Wall
++CPPFLAGS += $(shell $(PKG_CONFIG) --cflags x11)
++LDLIBS += $(shell $(PKG_CONFIG) --libs x11)
- $(OBJECTS): $(SOURCES)
+-$(OBJECTS): $(SOURCES)
- $(CC) $(FLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -c -o $@ $<
-+ $(CC) $(FLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -c -o $@ $<
++all: $(TARGET)
clean:
rm -rf $(TARGET) $(OBJECTS)
+
+ install: $(TARGET) $(MAN)
+- $(INSTALL) -o root -g root -m 0755 $(TARGET) $(PREFIX)/bin
++ $(INSTALL) -d $(DESTDIR)$(PREFIX)/bin
++ $(INSTALL) -o root -g root -m 0755 $(TARGET) $(DESTDIR)$(PREFIX)/bin
+
+
+ uninstall:
diff --git a/x11-terms/yeahconsole/yeahconsole-0.3.4-r1.ebuild b/x11-terms/yeahconsole/yeahconsole-0.3.4-r2.ebuild
index c8e1f6f147a0..094dd9841b02 100644
--- a/x11-terms/yeahconsole/yeahconsole-0.3.4-r1.ebuild
+++ b/x11-terms/yeahconsole/yeahconsole-0.3.4-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit toolchain-funcs
DESCRIPTION="yeahconsole turns an xterm or rxvt-unicode into a game-like console"
@@ -11,26 +12,17 @@ SRC_URI="http://phrat.de/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~hppa ~riscv x86"
-RDEPEND="
- x11-libs/libX11
-"
+
+RDEPEND="x11-libs/libX11"
DEPEND="
${RDEPEND}
- x11-base/xorg-proto
-"
-PATCHES=(
- "${FILESDIR}"/${P}-make.patch
-)
-
-src_compile() {
- tc-export CC
- emake
-}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-make.patch )
-src_install() {
- dodir /usr/bin
- emake PREFIX="${D}"/usr install
- dodoc README
+src_configure() {
+ tc-export CC PKG_CONFIG
}
pkg_postinst() {