summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-11 20:21:56 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-11 20:46:49 +0100
commitb8863eb8d396571ba2e777762b748b3e820d753d (patch)
tree630ba84c241d23e489df51acbb55b00fb8488e84 /x11-themes/nuvox/nuvox-07.1-r1.ebuild
parentx11-themes/fvwm-themes: Depend on virtual/imagemagick-tools (diff)
downloadgentoo-b8863eb8d396571ba2e777762b748b3e820d753d.tar.gz
gentoo-b8863eb8d396571ba2e777762b748b3e820d753d.tar.bz2
gentoo-b8863eb8d396571ba2e777762b748b3e820d753d.zip
x11-themes/nuvox: Depend on virtual/imagemagick-tools
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3907
Diffstat (limited to 'x11-themes/nuvox/nuvox-07.1-r1.ebuild')
-rw-r--r--x11-themes/nuvox/nuvox-07.1-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-themes/nuvox/nuvox-07.1-r1.ebuild b/x11-themes/nuvox/nuvox-07.1-r1.ebuild
new file mode 100644
index 000000000000..0c5df3fb92e3
--- /dev/null
+++ b/x11-themes/nuvox/nuvox-07.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+MY_P=nuvoX_${PV}
+
+DESCRIPTION="NuvoX SVG icon theme"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=38467"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="virtual/imagemagick-tools[png]"
+
+RESTRICT="strip binchecks"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e '/rm -fr/d' -e '/tar cf/d' buildset || die
+}
+
+src_compile() {
+ ./buildset || die
+}
+
+src_install() {
+ dodoc nuvoX_0.7/readme.txt
+ rm nuvoX_0.7/{readme,license}.txt
+
+ insinto /usr/share/icons/${PN}
+ doins -r nuvoX_0.7/*
+}