summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/windowmaker/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/windowmaker/files')
-rw-r--r--x11-wm/windowmaker/files/windowmaker-0.95.3-fix_underlinking.patch15
-rw-r--r--x11-wm/windowmaker/files/windowmaker-0.95.5-bsd_crash.patch28
-rw-r--r--x11-wm/windowmaker/files/windowmaker-0.95.6-webp_detection.patch70
-rw-r--r--x11-wm/windowmaker/files/wmaker.desktop7
4 files changed, 120 insertions, 0 deletions
diff --git a/x11-wm/windowmaker/files/windowmaker-0.95.3-fix_underlinking.patch b/x11-wm/windowmaker/files/windowmaker-0.95.3-fix_underlinking.patch
new file mode 100644
index 000000000000..cd88709dc148
--- /dev/null
+++ b/x11-wm/windowmaker/files/windowmaker-0.95.3-fix_underlinking.patch
@@ -0,0 +1,15 @@
+diff --git a/wmlib/Makefile.am b/wmlib/Makefile.am
+index 0f8201f..7b95d1f 100644
+--- a/wmlib/Makefile.am
++++ b/wmlib/Makefile.am
+@@ -2,6 +2,7 @@
+ AUTOMAKE_OPTIONS = no-dependencies
+
+ libWMaker_la_LDFLAGS = -version-info 1:1:0
++libWMaker_la_LIBADD = @LIBRARY_SEARCH_PATH@ @XLIBS@
+ lib_LTLIBRARIES = libWMaker.la
+
+ include_HEADERS = WMaker.h
+--
+1.7.8.6
+
diff --git a/x11-wm/windowmaker/files/windowmaker-0.95.5-bsd_crash.patch b/x11-wm/windowmaker/files/windowmaker-0.95.5-bsd_crash.patch
new file mode 100644
index 000000000000..a3e71375f621
--- /dev/null
+++ b/x11-wm/windowmaker/files/windowmaker-0.95.5-bsd_crash.patch
@@ -0,0 +1,28 @@
+From: François Tigeot <ftigeot@wolfpond.org>
+Date: Sat, 21 Sep 2013 10:34:51 +0000 (+0200)
+Subject: osdep_bsd.c: Fix a typo causing memory to be overwritten
+X-Git-Url: http://repo.or.cz/w/wmaker-crm.git/commitdiff_plain/38e088314a2a4b7f8031f50eb546c22e5024bdf4
+
+osdep_bsd.c: Fix a typo causing memory to be overwritten
+
+* When compiled on DragonFly+gcc 4.7.3, this out of bounds array element
+ initialization causes an important variable to be overwritten and a
+ subsequent WindowMaker crash
+
+* It was sheer luck other compilers/environments didn't exhibit any obvious
+ issue so far
+---
+
+diff --git a/src/osdep_bsd.c b/src/osdep_bsd.c
+index 3393240..ad504ad 100644
+--- a/src/osdep_bsd.c
++++ b/src/osdep_bsd.c
+@@ -86,7 +86,7 @@ Bool GetCommandForPid(int pid, char ***argv, int *argc)
+ mib[0] = CTL_KERN;
+ mib[1] = KERN_ARGMAX;
+ mib[2] = 0;
+- mib[4] = 0;
++ mib[3] = 0;
+
+ count = sizeof(argmax);
+ if (sysctl(mib, 2, &argmax, &count, NULL, 0) == -1)
diff --git a/x11-wm/windowmaker/files/windowmaker-0.95.6-webp_detection.patch b/x11-wm/windowmaker/files/windowmaker-0.95.6-webp_detection.patch
new file mode 100644
index 000000000000..a451486288f6
--- /dev/null
+++ b/x11-wm/windowmaker/files/windowmaker-0.95.6-webp_detection.patch
@@ -0,0 +1,70 @@
+From e1146e56e08af2a66aecedffc6ff31d8ddcb25f3 Mon Sep 17 00:00:00 2001
+From: Christophe CURIS <christophe.curis@free.fr>
+Date: Mon, 15 Dec 2014 23:49:29 +0100
+Subject: [PATCH] configure: rewrote the detection for WebP image library
+
+Unfortunately, the detection was broken because the header is using a hack
+on the function name to provide compatibility between different versions of
+the API, which means the usual link test, which uses a known name of a
+symbol, cannot work without also using the header to get the hack applied
+on the function's name.
+
+The new detection mechanism now simply check for both header and link at
+the same time, so we're probably safe until a Major API change is decided,
+in which case we will also have to update WRaster's code anyway.
+
+Signed-off-by: Christophe CURIS <christophe.curis@free.fr>
+---
+ m4/wm_imgfmt_check.m4 | 36 ++++++++++++++++++++++++++++--------
+ 1 files changed, 28 insertions(+), 8 deletions(-)
+
+diff --git a/m4/wm_imgfmt_check.m4 b/m4/wm_imgfmt_check.m4
+index cad2d72..d07e618 100644
+--- a/m4/wm_imgfmt_check.m4
++++ b/m4/wm_imgfmt_check.m4
+@@ -187,14 +187,34 @@ AC_DEFUN_ONCE([WM_IMGFMT_CHECK_TIFF],
+ # the variable 'supported_gfx'
+ # When not found, append info to variable 'unsupported'
+ AC_DEFUN_ONCE([WM_IMGFMT_CHECK_WEBP],
+-[WM_LIB_CHECK([WEBP], ["-lwebp"], [VP8DecodeLayer], [$XLFLAGS $XLIBS],
+- [wm_save_CFLAGS="$CFLAGS"
+- AS_IF([wm_fn_lib_try_compile "webp/decode.h" "" "return 0" ""],
+- [],
+- [AC_MSG_ERROR([found $CACHEVAR but could not find appropriate header - are you missing libwebp-dev package?])])
+- CFLAGS="$wm_save_CFLAGS"],
+- [supported_gfx], [GFXLIBS])dnl
+-]) dnl AC_DEFUN
++[AS_IF([test "x$enable_webp" = "xno"],
++ [unsupported="$unsupported WebP"],
++ [AC_CACHE_CHECK([for WebP support library], [wm_cv_imgfmt_webp],
++ [wm_cv_imgfmt_webp=no
++ dnl
++ dnl The library is using a special trick on the functions to provide
++ dnl compatibility between versions, so we cannot try linking against
++ dnl a symbol without first using the header to handle it
++ wm_save_LIBS="$LIBS"
++ LIBS="$LIBS -lwebp"
++ AC_TRY_LINK(
++ [@%:@include <webp/decode.h>],
++ [WebPGetFeatures(NULL, 1024, NULL);],
++ [wm_cv_imgfmt_webp="-lwebp"])
++ LIBS="$wm_save_LIBS"
++ AS_IF([test "x$enable_webp$wm_cv_imgfmt_webp" = "xyesno"],
++ [AC_MSG_ERROR([explicit WebP support requested but no library found])])dnl
++ ])
++ AS_IF([test "x$wm_cv_imgfmt_webp" = "xno"],
++ [unsupported="$unsupported WebP"
++ enable_webp="no"],
++ [supported_gfx="$supported_gfx WebP"
++ WM_APPEND_ONCE([$wm_cv_imgfmt_webp], [GFXLIBS])dnl
++ AC_DEFINE([USE_WEBP], [1],
++ [defined when valid Webp library with header was found])])dnl
++ ])
++AM_CONDITIONAL([USE_WEBP], [test "x$enable_webp" != "xno"])dnl
++])
+
+
+ # WM_IMGFMT_CHECK_XPM
+--
+1.7.6.6.GIT
+
diff --git a/x11-wm/windowmaker/files/wmaker.desktop b/x11-wm/windowmaker/files/wmaker.desktop
new file mode 100644
index 000000000000..fd24a0b00e0c
--- /dev/null
+++ b/x11-wm/windowmaker/files/wmaker.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+# The names/descriptions should really be better
+Name=GNUStep WindowMaker
+Comment=Use this session to run WindowMaker as your desktop environment
+Exec=/usr/bin/wmaker
+Icon=
+Type=Application