summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorSean Vig <sean.v.775@gmail.com>2023-08-03 20:18:51 -0400
committerSam James <sam@gentoo.org>2023-08-09 21:43:23 +0100
commit3baa5f49c4ee322996ab5f70f14137d303edf707 (patch)
treeb5addbd278b8a9293382ecd71f3e7e3332ccd12a /x11-wm
parentsci-libs/openlibm: add USE=static-libs (diff)
downloadgentoo-3baa5f49c4ee322996ab5f70f14137d303edf707.tar.gz
gentoo-3baa5f49c4ee322996ab5f70f14137d303edf707.tar.bz2
gentoo-3baa5f49c4ee322996ab5f70f14137d303edf707.zip
x11-wm/qtile: Fix Python syntax on replaced code
When not building with `pulseaudio` use flag, the `sed` replacement will insert code that `throw`'s an exception, rather than the correct syntax to `raise` the exception. Fix this typo. Signed-off-by: Sean Vig <sean.v.775@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32164 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/qtile/qtile-9999.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/x11-wm/qtile/qtile-9999.ebuild b/x11-wm/qtile/qtile-9999.ebuild
index 03829958fd7f..d1bf02722c9a 100644
--- a/x11-wm/qtile/qtile-9999.ebuild
+++ b/x11-wm/qtile/qtile-9999.ebuild
@@ -62,7 +62,7 @@ distutils_enable_tests pytest
python_prepare_all() {
# Avoid automagic dependency on libpulse
if ! use pulseaudio ; then
- sed -i -e 's/call("libpulse", "--libs")/throw PkgConfigError/' setup.py || die
+ sed -i -e 's/call("libpulse", "--libs")/raise PkgConfigError/' setup.py || die
fi
# Avoid automagic dependency on pywlroots