summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-15 20:02:03 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-15 20:02:03 +0200
commit4d51423fbfb15edd760b556c69a8a73093804572 (patch)
tree05b5f68196330f2089d60bad649b6630ee1bb197 /xfce-extra/xfce4-dict/xfce4-dict-0.8.4.ebuild
parentdev-libs/libevdev: Increase test timeout (diff)
downloadgentoo-4d51423fbfb15edd760b556c69a8a73093804572.tar.gz
gentoo-4d51423fbfb15edd760b556c69a8a73093804572.tar.bz2
gentoo-4d51423fbfb15edd760b556c69a8a73093804572.zip
xfce-extra/xfce4-dict: Bump to 0.8.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-dict/xfce4-dict-0.8.4.ebuild')
-rw-r--r--xfce-extra/xfce4-dict/xfce4-dict-0.8.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-dict/xfce4-dict-0.8.4.ebuild b/xfce-extra/xfce4-dict/xfce4-dict-0.8.4.ebuild
new file mode 100644
index 000000000000..28ad3e4c2e49
--- /dev/null
+++ b/xfce-extra/xfce4-dict/xfce4-dict-0.8.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="A dict.org querying application and panel plug-in for the Xfce desktop"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-dict"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.24
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfce4-panel-4.10:="
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ econf --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}