summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-08-10 13:37:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-14 20:14:04 +0200
commit90781e4b13f1add81b870dd267d8310c202d18a8 (patch)
tree6b8a4c49788a184891e704d6a9c2d3e00228188b /xfce-extra
parentxfce-extra/xfce4-verve-plugin: add 2.0.3 with new EAPI (diff)
downloadgentoo-90781e4b13f1add81b870dd267d8310c202d18a8.tar.gz
gentoo-90781e4b13f1add81b870dd267d8310c202d18a8.tar.bz2
gentoo-90781e4b13f1add81b870dd267d8310c202d18a8.zip
xfce-extra/xfce4-hdaps: bump EAPI, remove empty IUSE
- changed DEPENDs style to follow xfce-base/xfce4-session Signed-off-by: Filip Kobierski <fkobi@pm.me> Closes: https://github.com/gentoo/gentoo/pull/38056 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3-r1.ebuild b/xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..64f82e508edd
--- /dev/null
+++ b/xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Show the status of the IBM Hard Drive Active Protection System"
+HOMEPAGE="https://michael.orlitzky.com/code/xfce4-hdaps.xhtml"
+SRC_URI="https://michael.orlitzky.com/code/releases/${P}.tar.xz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=x11-libs/gtk+-3.20:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+"
+RDEPEND="
+ ${DEPEND}
+ app-laptop/hdapsd
+ app-laptop/tp_smapi
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}