summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-portage/gemato/Manifest1
-rw-r--r--app-portage/gemato/gemato-18.0.ebuild53
-rw-r--r--app-portage/gemato/gemato-9999.ebuild6
3 files changed, 58 insertions, 2 deletions
diff --git a/app-portage/gemato/Manifest b/app-portage/gemato/Manifest
index 1ae0ae6f35b2..a178bc2dc3e1 100644
--- a/app-portage/gemato/Manifest
+++ b/app-portage/gemato/Manifest
@@ -1 +1,2 @@
DIST gemato-17.0.tar.gz 83991 BLAKE2B 7a01b8ecb9e3540c698b7d57e5b6ba0961d42e7edd51e7b422d0e3d89088230633f3402b19168b3ccb772f028a3f669b324e76fa84f1918afa1c92c728942f14 SHA512 22066939ccab081c5d2bd52eab587aed0893b11cac40256a2e08a9a2f14e20320acaffd3414c4111bf27db15aca6d76a3856b6a3d8d5019fd649a2f7e07e3265
+DIST gemato-18.0.gh.tar.gz 85575 BLAKE2B a923c3d7731b70798d9baf7e9faf0884723bb5e15b4e24712ecd807b79e8ca7e1532f894cf6a3b675bd72419eac41f1481fcd34fb21c9989871141819b036fa2 SHA512 9491579c3d80f9b500da2a50aed173641d049293e37f11c3c06616ff49949cae16dfd274ae79dcacca4bb4c27baf30a5f3900f45fc3dfb2b9fb5da8139db63e3
diff --git a/app-portage/gemato/gemato-18.0.ebuild b/app-portage/gemato/gemato-18.0.ebuild
new file mode 100644
index 000000000000..7e02cc9bba9d
--- /dev/null
+++ b/app-portage/gemato/gemato-18.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE='threads(+)'
+
+inherit distutils-r1
+
+DESCRIPTION="Stand-alone Manifest generation & verification tool"
+HOMEPAGE="
+ https://github.com/projg2/gemato/
+ https://pypi.org/project/gemato/
+"
+SRC_URI="
+ https://github.com/projg2/gemato/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+IUSE="+gpg pretty-log tools"
+
+RDEPEND="
+ gpg? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+ pretty-log? (
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ test? (
+ >=app-crypt/gnupg-2.2.20-r1
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use tools; then
+ exeinto /usr/share/gemato
+ doexe utils/*.{bash,py}
+ fi
+}
diff --git a/app-portage/gemato/gemato-9999.ebuild b/app-portage/gemato/gemato-9999.ebuild
index a91d89381cb1..065c894ffff0 100644
--- a/app-portage/gemato/gemato-9999.ebuild
+++ b/app-portage/gemato/gemato-9999.ebuild
@@ -10,8 +10,10 @@ PYTHON_REQ_USE='threads(+)'
inherit distutils-r1 git-r3
DESCRIPTION="Stand-alone Manifest generation & verification tool"
-HOMEPAGE="https://github.com/projg2/gemato"
-SRC_URI=""
+HOMEPAGE="
+ https://github.com/projg2/gemato/
+ https://pypi.org/project/gemato/
+"
EGIT_REPO_URI="https://github.com/projg2/gemato.git"
LICENSE="BSD-2"