summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/wget2/files/wget2-1.99.2-autoconf270.patch26
-rw-r--r--net-misc/wget2/files/wget2-1.99.2-avoid_bashisms.patch84
-rw-r--r--net-misc/wget2/wget2-1.99.2.ebuild4
3 files changed, 114 insertions, 0 deletions
diff --git a/net-misc/wget2/files/wget2-1.99.2-autoconf270.patch b/net-misc/wget2/files/wget2-1.99.2-autoconf270.patch
new file mode 100644
index 000000000000..f4f3dc192638
--- /dev/null
+++ b/net-misc/wget2/files/wget2-1.99.2-autoconf270.patch
@@ -0,0 +1,26 @@
+From 580af869093cfda6bc8a9d5901850354a16b3666 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tim=20R=C3=BChsen?= <tim.ruehsen@gmx.de>
+Date: Fri, 25 Dec 2020 18:55:34 +0100
+Subject: [PATCH] * configure.ac: Use AC_CONFIG_MACRO_DIR only once
+
+This fixes #547 (autotools 2.70 is more restrictive).
+Reported by: Gabriele Balducci
+---
+ configure.ac | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 7e29b8cba..0a4dc05b9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -100,7 +100,6 @@ AC_CONFIG_FILES([include/wget/wgetver.h])
+
+ AC_CONFIG_SRCDIR([src/wget.c])
+ AC_CONFIG_HEADERS([config.h])
+-AC_CONFIG_MACRO_DIR([m4])
+
+ # Non-verbose make
+ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+--
+GitLab
+
diff --git a/net-misc/wget2/files/wget2-1.99.2-avoid_bashisms.patch b/net-misc/wget2/files/wget2-1.99.2-avoid_bashisms.patch
new file mode 100644
index 000000000000..9b57117135a9
--- /dev/null
+++ b/net-misc/wget2/files/wget2-1.99.2-avoid_bashisms.patch
@@ -0,0 +1,84 @@
+From c2a27f61db2de16fbadd1d52802c667cb0a2f819 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Tim=20R=C3=BChsen?= <tim.ruehsen@gmx.de>
+Date: Thu, 29 Oct 2020 23:05:18 +0100
+Subject: [PATCH] * configure.ac: Fix configure.ac bashisms
+
+Reported-by: Brian Inglis
+
+Backported to 1.99.2 release
+Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
+---
+ configure.ac | 18 +++++++++---------
+ 1 file changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index ab3d9fdf..158d5aea 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -350,13 +350,13 @@ if test "$enable_doc" = yes; then
+ if test -n "$DOXYGEN" || test -n "$PANDOC"; then
+ LIBWGET_DOCS_INFO="yes (found:"
+ if test -n "$DOXYGEN"; then
+- LIBWGET_DOCS_INFO+=" Doxygen)"
++ LIBWGET_DOCS_INFO="$LIBWGET_DOCS_INFO Doxygen)"
+ else
+ LIBWGET_DOCS_INFO="no"
+ fi
+ WGET2_DOCS_INFO="yes (found:"
+ if test -n "$PANDOC"; then
+- WGET2_DOCS_INFO+=" Pandoc)"
++ WGET2_DOCS_INFO="$WGET2_DOCS_INFO Pandoc)"
+ else
+ WGET2_DOCS_INFO="no"
+ fi
+@@ -440,7 +440,7 @@ PKG_PROG_PKG_CONFIG
+
+ AC_ARG_WITH(ssl, AS_HELP_STRING([--with-ssl], [Use SSL/TLS with specified library. Options: 'gnutls' (default), 'openssl', 'wolfssl' or 'none']), with_ssl=$withval, with_ssl=gnutls)
+
+-AS_IF([test "x$with_ssl" == "xgnutls"], [
++AS_IF([test "x$with_ssl" = "xgnutls"], [
+ PKG_CHECK_MODULES([GNUTLS], [gnutls], [
+ with_gnutls=yes
+ LIBS="$GNUTLS_LIBS $LIBS"
+@@ -454,14 +454,14 @@ AS_IF([test "x$with_ssl" == "xgnutls"], [
+
+ AS_IF([test "x$with_gnutls" == xyes], [
+ AC_SEARCH_LIBS(gnutls_hash, gnutls, [with_gnutls_hash=yes])
+- AS_IF([test "x$with_gnutls_hash" == xyes],
++ AS_IF([test "x$with_gnutls_hash" = xyes],
+ [AC_CHECK_HEADERS([gnutls/crypto.h], [], [], [#include <gnutls/gnutls.h>])])
+ AC_CHECK_HEADERS([gnutls/ocsp.h])
+ AC_CHECK_FUNCS(gnutls_srp_server_get_username gnutls_transport_get_int)
+ ])
+ ])
+
+-AS_IF([test "x$with_ssl" == "xopenssl"], [
++AS_IF([test "x$with_ssl" = "xopenssl"], [
+ PKG_CHECK_MODULES([OPENSSL], [openssl], [
+ with_openssl=yes
+ LIBS="$OPENSSL_LIBS $LIBS"
+@@ -474,7 +474,7 @@ AS_IF([test "x$with_ssl" == "xopenssl"], [
+ ])
+ ])
+
+- AS_IF([test "x$with_openssl" == xyes], [
++ AS_IF([test "x$with_openssl" = xyes], [
+ AC_CHECK_HEADERS([openssl/ssl.h])
+ AC_CHECK_HEADERS([openssl/x509_vfy.h])
+ AC_CHECK_FUNCS(SSL_new X509_STORE_add_lookup)
+@@ -846,9 +846,9 @@ AC_CONFIG_FILES([Makefile
+ AC_OUTPUT
+
+ # Check if expected TLS library was found and print it
+-AS_IF([test "x$with_ssl" == xwolfssl && test "x$with_wolfssl" == xno], [ssl_enabled="(not found)"],
+- [test "x$with_ssl" == xopenssl && test "x$with_openssl" == xno], [ssl_enabled="(not found)"],
+- [test "x$with_ssl" == xgnutls && test "x$with_gnutls" == xno], [ssl_enabled="(not found)"],
++AS_IF([test "x$with_ssl" = xwolfssl && test "x$with_wolfssl" = xno], [ssl_enabled="(not found)"],
++ [test "x$with_ssl" = xopenssl && test "x$with_openssl" = xno], [ssl_enabled="(not found)"],
++ [test "x$with_ssl" = xgnutls && test "x$with_gnutls" = xno], [ssl_enabled="(not found)"],
+ [])
+
+ AC_MSG_NOTICE([Summary of build options:
+--
+2.30.0
+
diff --git a/net-misc/wget2/wget2-1.99.2.ebuild b/net-misc/wget2/wget2-1.99.2.ebuild
index 6e48cfdc1eea..9b2066895e5e 100644
--- a/net-misc/wget2/wget2-1.99.2.ebuild
+++ b/net-misc/wget2/wget2-1.99.2.ebuild
@@ -52,6 +52,10 @@ PATCHES=(
# Upstream attempts to be "smart" by calling ldconfig in
# install-exec-hook
"${FILESDIR}"/${PN}-1.99.2-remove_ldconfig_call.patch
+
+ # Fixes from upstream
+ "${FILESDIR}"/${P}-avoid_bashisms.patch
+ "${FILESDIR}"/${P}-autoconf270.patch
)
src_prepare() {