summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/regex/Manifest1
-rw-r--r--dev-python/regex/regex-2016.01.10.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/regex/Manifest b/dev-python/regex/Manifest
index b374ecb8a063..3b264432b639 100644
--- a/dev-python/regex/Manifest
+++ b/dev-python/regex/Manifest
@@ -1,2 +1,3 @@
DIST regex-2015.07.12.tar.gz 554160 SHA256 9a39618645ce8c707c2c1346a3eeef0e441a9084df0739a5fcfe32059f68ebe1 SHA512 3b8cfa029744d17f06c659e6357d3a4520817656da6dcfc6952bbdac01fec266e8832fab649000fc7a3dacab508e2ae462728c139cc4cac913c40e2ae34abf54 WHIRLPOOL 86f004c6d8533071ef938ba39cfe34f198dcc56ab75883f8b5f2bc2dfaa40abc46b0ed64aa873821c6cc4e694c424dd8a16d97c35a6a1fafa7d2f84e09c59adf
DIST regex-2015.07.19.tar.gz 554541 SHA256 c1dc58206f458749040ba813ef65067d7018908cab4bb16f4f12d9c7631e48b7 SHA512 94845ae133e25bdc2bb6ee6093f38f7a9281a64cdf4e53817c80183a28d7d0e2173f16f048f29ba38b2b277fc974c46a2f7d3b2fe1a346bc5d35c5fa45cdac17 WHIRLPOOL 4b38bd745c43fa2832d93e20fb4066911c6a224a2d1b4c3afaf8f03dcdf6d8d39896b25843671e0ee6916257b428455f24bbd493222e1b7bfa67c0b2ab838d32
+DIST regex-2016.01.10.tar.gz 574017 SHA256 02a77606e3f4a0a16a2727ed8f067681635a56221e8fca863ff64b196d5d79e0 SHA512 4f4700ca746763f857449003d32d56b5aa8069e3b71b160e719633b0cf00f80efc0766d8e1e193977278f91bd3e73c87aab31bee23aec77557ac9b3652ff6a2f WHIRLPOOL 9d493c0695b5920dfa71d94636d9f2952cbd5db97f60ae68c30fdf81fdbdab05c4726a41dae036541de694ec1ca688acdb20eaa48e514865da26c9a9569e30a0
diff --git a/dev-python/regex/regex-2016.01.10.ebuild b/dev-python/regex/regex-2016.01.10.ebuild
new file mode 100644
index 000000000000..73727ade69d8
--- /dev/null
+++ b/dev-python/regex/regex-2016.01.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Alternative regular expression module to replace re"
+HOMEPAGE="https://bitbucket.org/mrabarnett/mrab-regex"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DOCS=( README docs/UnicodeProperties.txt )
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local msg="tests failed under ${EPYTHON}"
+ # https://bitbucket.org/mrabarnett/mrab-regex/issue/145/1-fail-in-testsuite-under-pypy
+ einfo "There is one trivial fail of test test_empty_array under pypy"
+
+ if python_is_python3; then
+ "${PYTHON}" Python3/test_regex.py || die $msg
+ else
+ "${PYTHON}" Python2/test_regex.py || die $msg
+ fi
+}
+
+python_install_all() {
+ local DOCS="${DOCS} docs/UnicodeProperties.txt"
+ use doc && local HTML_DOCS=( docs/Features.html )
+
+ distutils-r1_python_install_all
+}