summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/ronn-ng/ronn-ng-0.9.1-r2.ebuild53
-rw-r--r--eclass/ruby-ng.eclass2
-rw-r--r--eclass/ruby-utils.eclass2
3 files changed, 2 insertions, 55 deletions
diff --git a/app-text/ronn-ng/ronn-ng-0.9.1-r2.ebuild b/app-text/ronn-ng/ronn-ng-0.9.1-r2.ebuild
deleted file mode 100644
index 6e449818f541..000000000000
--- a/app-text/ronn-ng/ronn-ng-0.9.1-r2.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_EXTRADOC="AUTHORS CHANGES README.md"
-RUBY_FAKEGEM_GEMSPEC="ronn-ng.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Builds manuals in HTML and Unix man page format from Markdown"
-HOMEPAGE="https://github.com/apjanke/ronn-ng"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv sparc x86"
-
-IUSE=""
-
-RDEPEND+="!app-text/ronn"
-
-DEPS="
- >=dev-ruby/kramdown-2.1:2
- >=dev-ruby/nokogiri-1.9.0:0
-"
-
-ruby_add_rdepend "
- =dev-ruby/mustache-1*
- ${DEPS}
-"
-
-ruby_add_bdepend "${DEPS}"
-
-all_ruby_prepare() {
- sed -i -e '/mustache/ s/0.7/1.0/' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_prepare() {
- # Make sure that we always use the right interpreter during tests.
- sed -i -e "/output/ s:ronn:${RUBY} bin/ronn:" test/test_ronn.rb || die
- sed -i -e "1igem 'psych', '~> 3.0'" Rakefile || die
-}
-
-all_ruby_compile() {
- PATH="${S}/bin:${PATH}" rake man || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- doman man/ronn.1 man/ronn-format.7
-}
diff --git a/eclass/ruby-ng.eclass b/eclass/ruby-ng.eclass
index d808b7bd98b3..8befa086ef02 100644
--- a/eclass/ruby-ng.eclass
+++ b/eclass/ruby-ng.eclass
@@ -107,7 +107,7 @@ _ruby_get_all_impls() {
for i in ${USE_RUBY}; do
case ${i} in
# removed implementations
- ruby19|ruby20|ruby21|ruby22|ruby23|ruby24|ruby25|ruby26|jruby)
+ ruby19|ruby20|ruby21|ruby22|ruby23|ruby24|ruby25|ruby26|ruby27|jruby)
;;
*)
found_valid_impl=1
diff --git a/eclass/ruby-utils.eclass b/eclass/ruby-utils.eclass
index d34ce47706ad..eef2aba2fb99 100644
--- a/eclass/ruby-utils.eclass
+++ b/eclass/ruby-utils.eclass
@@ -33,7 +33,7 @@ if [[ ! ${_RUBY_UTILS} ]]; then
# provide for a better first installation experience.
# All stable RUBY_TARGETS
-RUBY_TARGETS_PREFERENCE="ruby30 ruby27 "
+RUBY_TARGETS_PREFERENCE="ruby30 "
# All other active ruby targets
RUBY_TARGETS_PREFERENCE+="ruby31 ruby32"