summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/udev/udev-249-r2.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/sys-fs/udev/udev-249-r2.ebuild b/sys-fs/udev/udev-249-r2.ebuild
index e6d857dcefb5..5dbd7be0b71c 100644
--- a/sys-fs/udev/udev-249-r2.ebuild
+++ b/sys-fs/udev/udev-249-r2.ebuild
@@ -279,6 +279,10 @@ multilib_src_install_all() {
einstalldocs
}
+pkg_preinst() {
+ has_version 'sys-fs/eudev' && HAD_EUDEV=1
+}
+
pkg_postinst() {
# Update hwdb database in case the format is changed by udev version.
if has_version 'sys-apps/hwids[udev]' ; then
@@ -287,4 +291,13 @@ pkg_postinst() {
# https://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
[[ -z ${REPLACING_VERSIONS} ]] && udev_reload
fi
+
+ if [[ ${HAD_EUDEV} -eq 1 ]] ; then
+ ewarn
+ ewarn "${P} defaults to predictable interface renaming, as described in the URL below:"
+ ewarn "https://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames"
+ ewarn
+ ewarn "If you wish to disable this, please see the above documentation, or set"
+ ewarn "net.ifnames=0 on the kernel command line."
+ fi
}