summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/krb5/Manifest1
-rw-r--r--dev-python/krb5/krb5-0.4.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/krb5/Manifest b/dev-python/krb5/Manifest
index 9a892f47fd69..dfa510ae1701 100644
--- a/dev-python/krb5/Manifest
+++ b/dev-python/krb5/Manifest
@@ -1 +1,2 @@
DIST krb5-0.3.0.tar.gz 1707212 BLAKE2B 0fa7a60372876f28cdbc2865fbd898c717aaaf22837bfd123008611973a0d6907ea9e5941d5da4ef707161d6aadd883fdef1faab81d307153eb4e115defe32a6 SHA512 5074cecfcd82c8f525d77c2faba5b34d6cdc593b15124741df1adec64cdde59fec2f17a02c04f78484ab4b82f7f37f5c1a4d856a2040c8d11c7e4a1b74307b27
+DIST krb5-0.4.0.tar.gz 218774 BLAKE2B 44bfe2226eda7b9175b059d4e634c64870ad03a34dcc6595bf7770e21e83b11b000a2bf076a749f88cfb0912b3dcc28974db1ba1273c03bcfab63a868c2165ed SHA512 d51b58b84985ccbb5440bea71a09c23889dd8ee2b14fa594f0f2330b0e318993e8c9627f5cc568585fe5e86847a3eb5f4a4775ea07d7936c03f69ce0fd141950
diff --git a/dev-python/krb5/krb5-0.4.0.ebuild b/dev-python/krb5/krb5-0.4.0.ebuild
new file mode 100644
index 000000000000..103a3189850c
--- /dev/null
+++ b/dev-python/krb5/krb5-0.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Kerberos API bindings for Python"
+HOMEPAGE="https://pypi.org/project/krb5/ https://github.com/jborean93/pykrb5"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ virtual/krb5
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? ( dev-python/k5test[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest