summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/thrift/Manifest1
-rw-r--r--dev-python/thrift/thrift-0.14.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/thrift/Manifest b/dev-python/thrift/Manifest
index 37af6138fd50..744b93011d8d 100644
--- a/dev-python/thrift/Manifest
+++ b/dev-python/thrift/Manifest
@@ -1 +1,2 @@
DIST thrift-0.13.0.tar.gz 59911 BLAKE2B b45363c2e8bbc5c7fae25533c7df9be49e6ea88b5ce077e9a580c28decf06de608d50100ba77cdb1ce8c7e56b87608d193b8579a4f89cc4fb74d672da0ba7e93 SHA512 063440db324efdae1fc4466133deaedeb1edd2f953f6924191ad819476f7b62a434d52960837e94516a673063ceab8b446b4f7dc8c94bb2d1fb84e95d2fa3d78
+DIST thrift-0.14.1.tar.gz 4311458 BLAKE2B 00c0b77c3d722b0db833f03848df0b74ee64712ed1ff06e0b63b926eb493f43ffd9c316422b6044f74685471cdbd2ccea7c6305fd8dbbc10614f2151a3e16237 SHA512 e09e53b2ea3cad01ef81ab4b5a87bfed443cfda849a13c4f00ba0ed1cd1a1f9742faf95adb07f279506cc5f866c13fdce57149de1bc9e71ab5c40238037e8b22
diff --git a/dev-python/thrift/thrift-0.14.1.ebuild b/dev-python/thrift/thrift-0.14.1.ebuild
new file mode 100644
index 000000000000..bc78792f8bff
--- /dev/null
+++ b/dev-python/thrift/thrift-0.14.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of Thrift"
+HOMEPAGE="https://pypi.org/project/thrift/ https://thrift.apache.org/"
+SRC_URI="https://downloads.apache.org/${PN}/${PV}//${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${P}/lib/py"
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+}