summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pyzotero/Manifest1
-rw-r--r--dev-python/pyzotero/pyzotero-1.4.25.ebuild39
2 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/pyzotero/Manifest b/dev-python/pyzotero/Manifest
index 7b0bfc956c70..103f0f963eaf 100644
--- a/dev-python/pyzotero/Manifest
+++ b/dev-python/pyzotero/Manifest
@@ -1,2 +1 @@
-DIST pyzotero-1.4.25.tar.gz 521569 BLAKE2B ce4e3587667078d295c0d2b7d0695aba0b9da22d40caa3aff405a6ed88b3061693d0d9d0db5bfdde074a3003b088705ed5c9443f3fa0f156d803114b25288b2b SHA512 d00d30da57d7f988b9e301d496a26bd983933567ffeb87d6d494dd7c93290315ad7fda8e791c4be382bedfda51ab5928ed37230f6649f60ce731f6b2f8ddfd39
DIST pyzotero-1.4.26.tar.gz 520629 BLAKE2B 7ddcd55a1c21d6dcc4b610a9a29bc86ff002afdf2e2a90513219b9fd13b3d5b504736e122850fc81acf7a4bbca0b8c5da3a92c8eb3a6f07392e3d17a9dc7d73c SHA512 a0b0bf92458746b0dd0c01511efb05dd8fb471434c9e813c9d6dab7741a2eb1a10af2b9c5f68daa4c681353ba8c93cab140ec2da5962d06c76e8a229d4742009
diff --git a/dev-python/pyzotero/pyzotero-1.4.25.ebuild b/dev-python/pyzotero/pyzotero-1.4.25.ebuild
deleted file mode 100644
index 03077463c22c..000000000000
--- a/dev-python/pyzotero/pyzotero-1.4.25.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-DESCRIPTION="A Python client for the Zotero API"
-HOMEPAGE="https://github.com/urschrei/pyzotero"
-SRC_URI="https://github.com/urschrei/pyzotero/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- app-text/zotero-bin
- dev-python/bibtexparser[${PYTHON_USEDEP}]
- <dev-python/feedparser-6[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/httpretty[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_sphinx doc --no-autodoc
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # do not install tests
- sed -i "s/find_packages(),/find_packages(exclude=('test*',)),/g" setup.py || die
-
- distutils-r1_python_prepare_all
-}