summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/aiocache/aiocache-0.12.2.ebuild25
-rw-r--r--dev-python/mkdocstrings-python/Manifest1
-rw-r--r--dev-python/mkdocstrings-python/mkdocstrings-python-1.3.0.ebuild41
-rw-r--r--dev-python/overrides/Manifest1
-rw-r--r--dev-python/overrides/overrides-7.4.0.ebuild21
-rw-r--r--dev-python/pygments/Manifest1
-rw-r--r--dev-python/pygments/pygments-2.16.1.ebuild46
-rw-r--r--dev-python/pypdf/Manifest1
-rw-r--r--dev-python/pypdf/pypdf-3.15.0.ebuild56
-rw-r--r--eclass/verify-sig.eclass4
10 files changed, 192 insertions, 5 deletions
diff --git a/dev-python/aiocache/aiocache-0.12.2.ebuild b/dev-python/aiocache/aiocache-0.12.2.ebuild
index bba70b471f05..654d767ca7eb 100644
--- a/dev-python/aiocache/aiocache-0.12.2.ebuild
+++ b/dev-python/aiocache/aiocache-0.12.2.ebuild
@@ -20,6 +20,7 @@ KEYWORDS="~amd64 ~x86"
BDEPEND="
test? (
+ dev-db/redis
>=dev-python/msgpack-0.5.5[${PYTHON_USEDEP}]
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
>=dev-python/redis-4.2.0[${PYTHON_USEDEP}]
@@ -30,9 +31,6 @@ distutils_enable_tests pytest
python_test() {
local EPYTEST_IGNORE=(
- # require running servers
- # TODO: start redis and enable them
- tests/acceptance
# benchmarks
tests/performance
# requires aiomcache
@@ -41,3 +39,24 @@ python_test() {
epytest -o addopts= -m "not memcached"
}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ # Spawn Redis for testing purposes
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1 ::1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}
diff --git a/dev-python/mkdocstrings-python/Manifest b/dev-python/mkdocstrings-python/Manifest
index e9fa980a5f55..079a5b4942cd 100644
--- a/dev-python/mkdocstrings-python/Manifest
+++ b/dev-python/mkdocstrings-python/Manifest
@@ -1 +1,2 @@
DIST mkdocstrings-python-1.2.1.gh.tar.gz 132468 BLAKE2B 287cae20510818c085bf505fea0f74e39df86538e19bfcb90aa7f6d46fb237158979dc65c7f955d73461fadb4ed35263ef47b9771f224b5793026a9f0b3c86e1 SHA512 147849a88c3bb5347c1cb4293c9ee9c54cb33933bc274dc5bc933f72deb64016c7f7b8ba817311e282c68606d0980571d5713dec7a47e8d6c51168d524af7d97
+DIST mkdocstrings-python-1.3.0.gh.tar.gz 132776 BLAKE2B 894068067f301f40ed9535cd929fdbd40aa396c9c09c0cee7887f50669465cd0422c0b9b240553193df7e7d4c90f0bf2b591000e6568ee3c47256fc5d1f79179 SHA512 caf806d6285281ef84ed78bd6295ec6732d454a602f55f825436d0a17e9ab62e33ac21510d0ccee5d33fb3c117ec416859ad90ce75d608649a277342d1dc5a1c
diff --git a/dev-python/mkdocstrings-python/mkdocstrings-python-1.3.0.ebuild b/dev-python/mkdocstrings-python/mkdocstrings-python-1.3.0.ebuild
new file mode 100644
index 000000000000..17104df0a441
--- /dev/null
+++ b/dev-python/mkdocstrings-python/mkdocstrings-python-1.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=pdm-backend
+
+inherit distutils-r1
+
+DESCRIPTION="Python handler for dev-python/mkdocstrings"
+HOMEPAGE="
+ https://mkdocstrings.github.io/python/
+ https://github.com/mkdocstrings/python/
+ https://pypi.org/project/mkdocstrings-python/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ <dev-python/griffe-0.33[${PYTHON_USEDEP}]
+ >=dev-python/griffe-0.30.0[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}
diff --git a/dev-python/overrides/Manifest b/dev-python/overrides/Manifest
index 586474b1809d..bd3a1aaaa72f 100644
--- a/dev-python/overrides/Manifest
+++ b/dev-python/overrides/Manifest
@@ -1 +1,2 @@
DIST overrides-7.3.1.tar.gz 24766 BLAKE2B c7fc2e22b7ded0208befd483e76b0bdb444f2d2891f6b2fe4751a81c47164b2cd3a51b7d71ec03401629d4427393553aed1146d2ef60ffe966fd502bd84e824e SHA512 94a8a581dfdacc047937824ffb8afae81d92998ec796e44c4ae05778f2b9d381517e37c2c4591a1c118b091f96bd91554aaef65d0372b2fef04f6ee225e10922
+DIST overrides-7.4.0.tar.gz 24804 BLAKE2B 9a9657d15ad835695d116559f1e6f51e14d1a0a9b5a237b2d468d9c6fd8d86368af53871490c257d7e6843fe02113a874524b8e55f4b3c9bcc7c827714cd5f44 SHA512 6ffd3b38997fd207d8ef9876ba9c328ef244b39300d22ae8c8bf63862f160b485d82b99d36d24abd1676fdddd39e5324eb0f1cf8629a0e17ac96956d165b6afd
diff --git a/dev-python/overrides/overrides-7.4.0.ebuild b/dev-python/overrides/overrides-7.4.0.ebuild
new file mode 100644
index 000000000000..5682e8b4c541
--- /dev/null
+++ b/dev-python/overrides/overrides-7.4.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A decorator to automatically detect mismatch when overriding a method."
+HOMEPAGE="
+ https://pypi.org/project/overrides/
+ https://github.com/mkorpela/overrides/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~s390"
+
+distutils_enable_tests pytest
diff --git a/dev-python/pygments/Manifest b/dev-python/pygments/Manifest
index 9d82f247507e..00ec05f171be 100644
--- a/dev-python/pygments/Manifest
+++ b/dev-python/pygments/Manifest
@@ -1 +1,2 @@
DIST Pygments-2.15.1.tar.gz 4819591 BLAKE2B f42d3342b88c5b5745fbfbd1f76913f7d17745d396311a39627aca8e968445b19983e7c633583097c495ce6f43a6a7224262a7c35645751803b6c1172062d8c0 SHA512 408f0bbbc8226ee91b82ed084d178f114657150bcf9381dd34debb704399ccdb2e78cb5578ff297797771660d7263c51c305d03b2a27ae29269110be0bca50a9
+DIST Pygments-2.16.1.tar.gz 4872980 BLAKE2B 57ec4f52f2bca3d9df993f583434d61ad0adbc2719f2d0b4ac84160672a3a57ec144509c520f2724a15f0222548abfbe0e743fa31a8dac64d54111b2d7393ae4 SHA512 9b66c79c03e7ecd36cc00efd428a0a6b372e70dbccdcaae26eff4d56c07a17e2e00d2cf0291eb6624ffd1c896b797789b973e80ccbca4240d56daad95eacfd80
diff --git a/dev-python/pygments/pygments-2.16.1.ebuild b/dev-python/pygments/pygments-2.16.1.ebuild
new file mode 100644
index 000000000000..781fe60b07a3
--- /dev/null
+++ b/dev-python/pygments/pygments-2.16.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 bash-completion-r1 pypi
+
+DESCRIPTION="Pygments is a syntax highlighting package written in Python"
+HOMEPAGE="
+ https://pygments.org/
+ https://github.com/pygments/pygments/
+ https://pypi.org/project/Pygments/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/wcag-contrast-ratio[${PYTHON_USEDEP}]
+ virtual/ttf-fonts
+ )
+"
+
+EPYTEST_DESELECT=(
+ # fuzzing tests, very slow
+ tests/test_basic_api.py::test_random_input
+ # incompatibility with python-ctags3, apparently
+ # https://github.com/pygments/pygments/issues/2486
+ tests/test_html_formatter.py::test_ctags
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp external/pygments.bashcomp pygmentize
+}
diff --git a/dev-python/pypdf/Manifest b/dev-python/pypdf/Manifest
index 3737a00dd765..f282ad554968 100644
--- a/dev-python/pypdf/Manifest
+++ b/dev-python/pypdf/Manifest
@@ -1,5 +1,6 @@
DIST pypdf-3.12.2.gh.tar.gz 7560560 BLAKE2B f00047287619e49829d516f06020119f2ff19e0d4e67ccf4e45c05b1bff66ca3e69a03da99113accb818b8873ae5e637d23991925633ac01a20dcd35a15d1609 SHA512 b888c81cc3cb331f7b5709c4fa29c9f2f0790fc67679112de9e48f31cb20047b7622bcb8e555d5113e6dea96ec5d1c2759ac84696278123eb5a7faeea727b192
DIST pypdf-3.13.0.gh.tar.gz 7563894 BLAKE2B f2f34dccda87e719b326b4c48331e9813a36dbecd14d26f9268b44891939fb3dac3a2bf2e298efd927e8fe97869f43d39f2890008858d42255c31f6496e2003a SHA512 6259b242aaba8e0b63b988749850aa2138b802eaf52d146793635ff723956f19b1989c3c76278ed4240acbc88f8dd4b7e64fcf777508e98dee81093d794b2945
DIST pypdf-3.14.0.gh.tar.gz 7572714 BLAKE2B 5a706eb9f9965de9ec3e3b03e243b629700b0c43b0549d49c33cc0a4d5ab570c75aa03695ccb8b08dac99032e9c4c170f2511c0dc644fed90d14da4a3fd18dbd SHA512 f7fc45a10249d3a86e60ed73f8e9a226a8bbb3fe181efdc8102128b7005a39f2479386801d18e8d6be56e8a12b5d3c8769a9c5504df27bec981ebe9cf22da205
+DIST pypdf-3.15.0.gh.tar.gz 7673228 BLAKE2B 9516d5e7865fa5c3bed90461d2e12ad1a400b755d8254330837e8b5f313f985bd199da9a19b2a189623b392c6ae76fd757e68c1454d09a7b5ec70bc28bff3485 SHA512 a9dc59141918fe47d1b2ec0fc282e31c05ef3df137cc67e85d965172929b3b1bbc38f8827a82a576f02c18b72cdca297364f58814f960b7783a36228a7e29125
DIST pypdf-sample-files-2cf1e75af7bcb9c097deae6fb112c715d4721744.gh.tar.gz 10226061 BLAKE2B a9b32d6cd3d22bbc0aee54ca3e914c4d2eb2a9a44a1a508e54e0a8fbcb5fad9ab05e72cf66553a1b5595131104ff22dea115d2804d2970200c4cf5f808532174 SHA512 f064f0468b07bf705a1d0f3a0fc6fe535c234a39408dca268f223e7c3548e66f599a4e67156e7848b70e9a3bd1bc2756395dd93b0c828ee08fe2bb8833f2b196
DIST pypdf-sample-files-5b5ee6b0e9bf4b683490351b1e15e01d6553da7b.gh.tar.gz 10226115 BLAKE2B 7488897284b840c7d4c26525425d326024936654cea42c47f260d1bc61a32a5c1da0a7eb8a9ad532857ea5c2db3446ce5850c509f44ccf6143b8cf4cb826e6c9 SHA512 70d4f0b6957160698afdc9b5bfb9d197f55f1651bc2ec2326621bb77bae5460fe0d4d8543ddbb7ed270c2bd36ad0ccae14deae6040d7f4a01db52374b820fd7e
diff --git a/dev-python/pypdf/pypdf-3.15.0.ebuild b/dev-python/pypdf/pypdf-3.15.0.ebuild
new file mode 100644
index 000000000000..14dbc17b22a9
--- /dev/null
+++ b/dev-python/pypdf/pypdf-3.15.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+SAMPLE_COMMIT=5b5ee6b0e9bf4b683490351b1e15e01d6553da7b
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/pypdf/
+ https://github.com/py-pdf/pypdf/
+"
+SRC_URI="
+ https://github.com/py-pdf/pypdf/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
+ -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
+ )
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.0.0[jpeg,jpeg2k,tiff,${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # rely on -Werror
+ tests/test_utils.py::test_deprecate_no_replacement
+ tests/test_workflows.py::test_orientations
+ # TODO: requires fpdf
+ tests/test_page.py::test_compression
+)
+
+src_unpack() {
+ default
+ if use test; then
+ mv "sample-files-${SAMPLE_COMMIT}"/* "${S}"/sample-files/ || die
+ fi
+}
+
+python_test() {
+ epytest -o addopts= -m "not enable_socket"
+}
diff --git a/eclass/verify-sig.eclass b/eclass/verify-sig.eclass
index 6472e995e827..d99dc3461858 100644
--- a/eclass/verify-sig.eclass
+++ b/eclass/verify-sig.eclass
@@ -16,7 +16,7 @@
# the developer's work.
#
# To use the eclass, start by packaging the upstream's key
-# as app-crypt/openpgp-keys-*. Then inherit the eclass, add detached
+# as sec-keys/openpgp-keys-*. Then inherit the eclass, add detached
# signatures to SRC_URI and set VERIFY_SIG_OPENPGP_KEY_PATH. The eclass
# provides verify-sig USE flag to toggle the verification.
#
@@ -35,7 +35,7 @@
# SRC_URI="https://example.org/${P}.tar.gz
# verify-sig? ( https://example.org/${P}.tar.gz.sig )"
# BDEPEND="
-# verify-sig? ( app-crypt/openpgp-keys-example )"
+# verify-sig? ( sec-keys/openpgp-keys-example )"
#
# VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/example.asc
# @CODE