summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-fs/tahoe-lafs/tahoe-lafs-1.10.2.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/net-fs/tahoe-lafs/tahoe-lafs-1.10.2.ebuild b/net-fs/tahoe-lafs/tahoe-lafs-1.10.2.ebuild
index bb0f4bca8131..031d09ff8c46 100644
--- a/net-fs/tahoe-lafs/tahoe-lafs-1.10.2.ebuild
+++ b/net-fs/tahoe-lafs/tahoe-lafs-1.10.2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="sqlite"
@@ -26,19 +26,19 @@ RDEPEND="
dev-python/nevow[${PYTHON_USEDEP}]
>=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]
dev-python/pyasn1-modules[${PYTHON_USEDEP}]
- dev-python/pycrypto[${PYTHON_USEDEP}]
dev-python/pycryptopp[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
dev-python/pyutil[${PYTHON_USEDEP}]
dev-python/service_identity[${PYTHON_USEDEP}]
dev-python/simplejson[${PYTHON_USEDEP}]
- >=dev-python/twisted-core-13.0.0[${PYTHON_USEDEP}]
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
dev-python/zbase32[${PYTHON_USEDEP}]
dev-python/zfec[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
src_prepare() {
rm -r setuptools* setup.cfg || die
@@ -49,10 +49,3 @@ src_install() {
distutils-r1_src_install
use doc && dodoc -r docs/*
}
-
-pkg_postinst() {
- elog
- elog "optional dependencies:"
- elog " dev-python/twisted-conch (for sftp access)"
- elog
-}