summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pefile/Manifest1
-rw-r--r--dev-python/pefile/pefile-2024.8.26.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pefile/Manifest b/dev-python/pefile/Manifest
index c776143f6b89..9bbd3bcb3026 100644
--- a/dev-python/pefile/Manifest
+++ b/dev-python/pefile/Manifest
@@ -1 +1,2 @@
DIST pefile-2023.2.7.gh.tar.gz 74852 BLAKE2B ddca4b8ef37af829bb1757eb4c4ba9f46c3914e05e6c13e13a8e5a3c88a608aba486deec9338400fddae4591867c0c7dcf7325cee14d42b1bb724751a3a2a7f0 SHA512 241d9846954f094ed39e61d80e7d8c1612829ec909650175e75657f9cf69c9bef9e2a115d4106bb14757125c0ffaa3e93abfb2f078e80326e78ac5818c7c2fd3
+DIST pefile-2024.8.26.gh.tar.gz 76008 BLAKE2B 7f21d07bbe9a08239739f589e35d0ef4b5172e26b2a90acdbedc7792be70fdb0d4ee01888d674384fb011f3c716406c1b1a23b29fa412ce01863cae89acbc4bc SHA512 62781f2ab84040a13304ce550dd1e943991df152c5f2951281906e837b1659694051a074ff49cd08d5d508e9b70009b56418a4237511c4464c4eba9bda4bccf7
diff --git a/dev-python/pefile/pefile-2024.8.26.ebuild b/dev-python/pefile/pefile-2024.8.26.ebuild
new file mode 100644
index 000000000000..3eecccc699f3
--- /dev/null
+++ b/dev-python/pefile/pefile-2024.8.26.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="Module to read and work with Portable Executable (PE) files"
+HOMEPAGE="https://github.com/erocarrera/pefile"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/erocarrera/pefile.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/erocarrera/pefile/releases/download/v${PV}/${P}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+# Unfortunately there is nothing we can test here. Upstream doesn't ship a test
+# suite inside the release files. The test fixtures in the source repo is
+# encrypted so that only their CI pipeline is able to run the tests.
+RESTRICT="test"