summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/libetonyek/files/libetonyek-0.1.8-glm-0.9.9.patch12
-rw-r--r--app-text/libetonyek/libetonyek-0.1.8.ebuild9
2 files changed, 18 insertions, 3 deletions
diff --git a/app-text/libetonyek/files/libetonyek-0.1.8-glm-0.9.9.patch b/app-text/libetonyek/files/libetonyek-0.1.8-glm-0.9.9.patch
new file mode 100644
index 000000000000..db78fa81d471
--- /dev/null
+++ b/app-text/libetonyek/files/libetonyek-0.1.8-glm-0.9.9.patch
@@ -0,0 +1,12 @@
+Gentoo-bug: https://bugs.gentoo.org/657820
+
+--- a/configure.ac 2018-03-18 14:51:31.000000000 +0100
++++ b/configure.ac 2018-07-11 23:13:14.901127036 +0200
+@@ -119,7 +119,6 @@
+ saved_CPPFLAGS="${CPPFLAGS}"
+ CPPFLAGS="${GLM_CFLAGS} ${CPPFLAGS}"
+ GLM_headers="glm/glm.hpp"
+-AS_IF([test "x$enable_tests" == "xyes"], [GLM_headers="$GLM_headers glm/gtx/io.hpp"], [])
+ AC_CHECK_HEADERS(
+ [$GLM_headers],
+ [],
diff --git a/app-text/libetonyek/libetonyek-0.1.8.ebuild b/app-text/libetonyek/libetonyek-0.1.8.ebuild
index 39b6f10a69f8..7e445ac2171a 100644
--- a/app-text/libetonyek/libetonyek-0.1.8.ebuild
+++ b/app-text/libetonyek/libetonyek-0.1.8.ebuild
@@ -4,7 +4,8 @@
EAPI=6
EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libetonyek.git"
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
+[[ ${PV} == 9999 ]] && inherit git-r3
+inherit autotools
DESCRIPTION="Library parsing Apple Keynote presentations"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libetonyek"
@@ -20,7 +21,7 @@ RDEPEND="
app-text/liblangtag
dev-libs/librevenge
dev-libs/libxml2
- sys-libs/zlib
+ sys-libs/zlib:=
"
DEPEND="${RDEPEND}
dev-libs/boost
@@ -32,10 +33,12 @@ DEPEND="${RDEPEND}
test? ( dev-util/cppunit )
"
+PATCHES=( "${FILESDIR}/${P}-glm-0.9.9.patch" )
+
src_prepare() {
default
[[ -d m4 ]] || mkdir "m4"
- [[ ${PV} == 9999 ]] && eautoreconf
+ eautoreconf
}
src_configure() {