summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/rocPRIM/rocPRIM-6.1.1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-libs/rocPRIM/rocPRIM-6.1.1.ebuild b/sci-libs/rocPRIM/rocPRIM-6.1.1.ebuild
index cd85f27b6500..5829c9167987 100644
--- a/sci-libs/rocPRIM/rocPRIM-6.1.1.ebuild
+++ b/sci-libs/rocPRIM/rocPRIM-6.1.1.ebuild
@@ -42,6 +42,8 @@ src_prepare() {
}
src_configure() {
+ rocm_use_hipcc
+
local mycmakeargs=(
-DCMAKE_SKIP_RPATH=ON
-DAMDGPU_TARGETS="$(get_amdgpu_flags)"
@@ -51,7 +53,7 @@ src_configure() {
-DROCM_SYMLINK_LIBS=OFF
)
- CXX=hipcc cmake_src_configure
+ cmake_src_configure
}
src_test() {