summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-physics/yoda/yoda-1.9.10.ebuild22
-rw-r--r--sci-physics/yoda/yoda-1.9.9.ebuild22
2 files changed, 42 insertions, 2 deletions
diff --git a/sci-physics/yoda/yoda-1.9.10.ebuild b/sci-physics/yoda/yoda-1.9.10.ebuild
index ea206e059b09..cab2ee9ece18 100644
--- a/sci-physics/yoda/yoda-1.9.10.ebuild
+++ b/sci-physics/yoda/yoda-1.9.10.ebuild
@@ -80,7 +80,27 @@ src_test() {
src_install() {
emake install DESTDIR="${ED}"
- newbashcomp "${ED}"/etc/bash_completion.d/${PN}-completion ${PN}
+ if use python ; then
+ newbashcomp "${ED}"/etc/bash_completion.d/${PN}-completion ${PN}
+ bashcomp_alias ${PN} ${PN}-config
+ bashcomp_alias ${PN} ${PN}stack \
+ aida2flat \
+ ${PN}diff \
+ ${PN}cnv \
+ ${PN}hist \
+ ${PN}-config \
+ ${PN}2flat \
+ ${PN}scale \
+ ${PN}2root \
+ ${PN}cmp \
+ ${PN}merge \
+ ${PN}plot \
+ aida2${PN} \
+ ${PN}ls \
+ ${PN}envelope \
+ ${PN}2aida
+ fi
+
rm "${ED}"/etc/bash_completion.d/${PN}-completion || die
use python && python_optimize
diff --git a/sci-physics/yoda/yoda-1.9.9.ebuild b/sci-physics/yoda/yoda-1.9.9.ebuild
index bb8f1e8ffb59..0294b67c3cf3 100644
--- a/sci-physics/yoda/yoda-1.9.9.ebuild
+++ b/sci-physics/yoda/yoda-1.9.9.ebuild
@@ -80,7 +80,27 @@ src_test() {
src_install() {
emake install DESTDIR="${ED}"
- newbashcomp "${ED}"/etc/bash_completion.d/${PN}-completion ${PN}
+ if use python ; then
+ newbashcomp "${ED}"/etc/bash_completion.d/${PN}-completion ${PN}
+ bashcomp_alias ${PN} ${PN}-config
+ bashcomp_alias ${PN} ${PN}stack \
+ aida2flat \
+ ${PN}diff \
+ ${PN}cnv \
+ ${PN}hist \
+ ${PN}-config \
+ ${PN}2flat \
+ ${PN}scale \
+ ${PN}2root \
+ ${PN}cmp \
+ ${PN}merge \
+ ${PN}plot \
+ aida2${PN} \
+ ${PN}ls \
+ ${PN}envelope \
+ ${PN}2aida
+ fi
+
rm "${ED}"/etc/bash_completion.d/${PN}-completion || die
use python && python_optimize