summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/inkscape/Manifest1
-rw-r--r--media-gfx/inkscape/files/inkscape-1.3.2-cxx20-2.patch11
-rw-r--r--media-gfx/inkscape/files/inkscape-1.3.2-cxx20.patch91
-rw-r--r--media-gfx/inkscape/files/inkscape-1.3.2-libxml2-2.12.patch29
-rw-r--r--media-gfx/inkscape/files/inkscape-1.3.2-poppler-24.03.patch61
-rw-r--r--media-gfx/inkscape/files/inkscape-1.3.2-poppler-24.05.patch64
-rw-r--r--media-gfx/inkscape/inkscape-1.3.2-r2.ebuild213
7 files changed, 0 insertions, 470 deletions
diff --git a/media-gfx/inkscape/Manifest b/media-gfx/inkscape/Manifest
index 4a8d70c059b9..451ba470c5b6 100644
--- a/media-gfx/inkscape/Manifest
+++ b/media-gfx/inkscape/Manifest
@@ -1,2 +1 @@
-DIST inkscape-1.3.2.tar.xz 44720944 BLAKE2B 24120f8c671e1fb54bb6626cab95e7086e3c60fbc117bbe8017d081c799bc26812b1286e670771e7ffe88720ba25f237146c452afaf65c1ee2ee554fb07f79a2 SHA512 a6da4b676ba3e7f954f95e3916ce78ce358b49c8052795a52d478064ef02eeae0337b0a94e89b9752ea6824a5758d28072c2bbf83f1e9ee28daebd3b0ef87343
DIST inkscape-1.4.tar.xz 46321868 BLAKE2B 3f21402019995122f043f5ebd8f07e1c9548c507f27c494e4214e090c46acae016c21f950609c95cef2e1b0011693e6629326d733b257402391e2d919bcd0303 SHA512 3b81306b81416597073e7eda2a103112cee63493bcf96fa737bb1edfbd682ebb329e415bbbbfda877aef2a78dc376460040ebc5c0cc2c90c0fe60db5d7d12368
diff --git a/media-gfx/inkscape/files/inkscape-1.3.2-cxx20-2.patch b/media-gfx/inkscape/files/inkscape-1.3.2-cxx20-2.patch
deleted file mode 100644
index 6364c3f88a9e..000000000000
--- a/media-gfx/inkscape/files/inkscape-1.3.2-cxx20-2.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/ui/dialog/filter-effects-dialog.cpp
-+++ b/src/ui/dialog/filter-effects-dialog.cpp
-@@ -202,7 +202,7 @@
- template< typename T> class ComboWithTooltip : public Gtk::EventBox
- {
- public:
-- ComboWithTooltip<T>(T default_value, const Util::EnumDataConverter<T>& c, const SPAttr a = SPAttr::INVALID, char* tip_text = nullptr)
-+ ComboWithTooltip(T default_value, const Util::EnumDataConverter<T>& c, const SPAttr a = SPAttr::INVALID, char* tip_text = nullptr)
- {
- if (tip_text) {
- set_tooltip_text(tip_text);
diff --git a/media-gfx/inkscape/files/inkscape-1.3.2-cxx20.patch b/media-gfx/inkscape/files/inkscape-1.3.2-cxx20.patch
deleted file mode 100644
index 3c61b1919278..000000000000
--- a/media-gfx/inkscape/files/inkscape-1.3.2-cxx20.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-From 1798e9c13b786f3d077ba0132592c4d5c1d1fb9b Mon Sep 17 00:00:00 2001
-From: Tavmjong Bah <tavmjong@free.fr>
-Date: Tue, 26 Sep 2023 19:23:27 +0000
-Subject: [PATCH] Up C++ version to C++20.
-
----
- CMakeLists.txt | 4 ++--
- _clang-format | 2 +-
- src/ui/knot/knot-holder-entity.cpp | 2 +-
- src/ui/tools/pencil-tool.cpp | 9 ++++++---
- 4 files changed, 10 insertions(+), 7 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index fe6b10cda24..de2680bd651 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -18,9 +18,9 @@ message("Binary Dir: ${CMAKE_CURRENT_BINARY_DIR}")
- # -----------------------------------------------------------------------------
- # CMake Configuration
- # -----------------------------------------------------------------------------
--set(CMAKE_CXX_STANDARD 17)
-+set(CMAKE_CXX_STANDARD 20)
- set(CMAKE_CXX_STANDARD_REQUIRED ON)
--# set(CMAKE_CXX_EXTENSIONS OFF) # enforces -std=c++17 instead of -std=gnu++17
-+# set(CMAKE_CXX_EXTENSIONS OFF) # enforces -std=c++20 instead of -std=gnu++20
- # TODO: build currently fails with it as we actually depend on GNU compiler extensions...
- # mostly use of the non-Standard M_PI et al. TODO: C++20: Use the <numbers> header.
-
-diff --git a/_clang-format b/_clang-format
-index 39396fad65a..48de4d2bd88 100644
---- a/_clang-format
-+++ b/_clang-format
-@@ -103,7 +103,7 @@ SpacesInContainerLiterals: false
- SpacesInCStyleCastParentheses: false
- SpacesInParentheses: false
- SpacesInSquareBrackets: false
--Standard: c++17
-+Standard: c++20
- StatementMacros: []
- TypenameMacros: []
- TabWidth: 4
-diff --git a/src/ui/knot/knot-holder-entity.cpp b/src/ui/knot/knot-holder-entity.cpp
-index 8703f5975f7..add66d2fa29 100644
---- a/src/ui/knot/knot-holder-entity.cpp
-+++ b/src/ui/knot/knot-holder-entity.cpp
-@@ -315,7 +315,7 @@ void PatternKnotHolderEntityScale::knot_set(Geom::Point const &p, Geom::Point co
- double scale_x = std::clamp(new_extent[X] / _cached_diagonal[X], _cached_min_scale, 1e9);
- double scale_y = std::clamp(new_extent[Y] / _cached_diagonal[Y], _cached_min_scale, 1e9);
-
-- Affine new_transform = (state & GDK_CONTROL_MASK) ? Scale(lerp(0.5, scale_x, scale_y))
-+ Affine new_transform = (state & GDK_CONTROL_MASK) ? Scale((scale_x + scale_y) * 0.5)
- : Scale(scale_x, scale_y);
-
- // 2. Calculate offset to keep pattern origin aligned
-diff --git a/src/ui/tools/pencil-tool.cpp b/src/ui/tools/pencil-tool.cpp
-index fd2d08cad0c..7324f7c8515 100644
---- a/src/ui/tools/pencil-tool.cpp
-+++ b/src/ui/tools/pencil-tool.cpp
-@@ -17,7 +17,11 @@
- * Released under GNU GPL v2+, read the file 'COPYING' for more information.
- */
-
--#include <numeric> // For std::accumulate
-+#include "pencil-tool.h"
-+
-+#include <cmath> // std::lerp
-+#include <numeric> // std::accumulate
-+
- #include <gdk/gdkkeysyms.h>
- #include <glibmm/i18n.h>
-
-@@ -26,7 +30,6 @@
- #include <2geom/sbasis-to-bezier.h>
- #include <2geom/svg-path-parser.h>
-
--#include "pencil-tool.h"
-
- #include "context-fns.h"
- #include "desktop.h"
-@@ -806,7 +809,7 @@ void PencilTool::_addFreehandPoint(Geom::Point const &p, guint /*state*/, bool l
- min = max;
- }
- double dezoomify_factor = 0.05 * 1000 / _desktop->current_zoom();
-- double const pressure_shrunk = pressure * (max - min) + min; // C++20 -> use std::lerp()
-+ double const pressure_shrunk = std::lerp(min, max, pressure);
- double pressure_computed = std::abs(pressure_shrunk * dezoomify_factor);
- double pressure_computed_scaled = std::abs(pressure_computed * _desktop->getDocument()->getDocumentScale().inverse()[Geom::X]);
- if (p != p_array[_npoints - 1]) {
---
-GitLab
-
diff --git a/media-gfx/inkscape/files/inkscape-1.3.2-libxml2-2.12.patch b/media-gfx/inkscape/files/inkscape-1.3.2-libxml2-2.12.patch
deleted file mode 100644
index 7e981e36fc1e..000000000000
--- a/media-gfx/inkscape/files/inkscape-1.3.2-libxml2-2.12.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-https://bugs.gentoo.org/923247
-https://gitlab.com/inkscape/inkscape/-/merge_requests/6089
-
-From 694d8ae43d06efff21adebf377ce614d660b24cd Mon Sep 17 00:00:00 2001
-From: Christian Hesse <mail@eworm.de>
-Date: Fri, 17 Nov 2023 22:30:42 +0100
-Subject: [PATCH] include missing header file
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-This fixes build error:
-```
-/build/inkscape/src/inkscape/src/object/uri.cpp: In constructor ‘Inkscape::URI::URI(const gchar*, const char*)’:
-/build/inkscape/src/inkscape/src/object/uri.cpp:86:9: error: ‘xmlFree’ was not declared in this scope; did you mean ‘xmlFreeURI’?
- 86 | xmlFree(full);
-```
---- a/src/object/uri.h
-+++ b/src/object/uri.h
-@@ -13,6 +13,7 @@
- #define INKSCAPE_URI_H
-
- #include <libxml/uri.h>
-+#include <libxml/xmlmemory.h>
- #include <memory>
- #include <string>
-
---
-GitLab
diff --git a/media-gfx/inkscape/files/inkscape-1.3.2-poppler-24.03.patch b/media-gfx/inkscape/files/inkscape-1.3.2-poppler-24.03.patch
deleted file mode 100644
index 53cf3fd2b6cd..000000000000
--- a/media-gfx/inkscape/files/inkscape-1.3.2-poppler-24.03.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From 3dd9846ab99260134e11938f0e575be822507037 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Mon, 4 Mar 2024 22:59:40 +0100
-Subject: [PATCH] Fix build with >=poppler-24.03.0
-
-Fixes build errors caused by:
-
-"Use an enum for Function getType"
-Upstream commit 6e3824d45d42cb806a28a2df84e4ab6bb3587083
-
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- src/extension/internal/pdfinput/svg-builder.cpp | 14 +++++++++++++-
- 1 file changed, 13 insertions(+), 1 deletion(-)
-
-diff --git a/src/extension/internal/pdfinput/svg-builder.cpp b/src/extension/internal/pdfinput/svg-builder.cpp
-index 525fbfec0..bcd7b1f61 100644
---- a/src/extension/internal/pdfinput/svg-builder.cpp
-+++ b/src/extension/internal/pdfinput/svg-builder.cpp
-@@ -1175,9 +1175,13 @@ static bool svgGetShadingColor(GfxShading *shading, double offset, GfxColor *res
- #define INT_EPSILON 8
- bool SvgBuilder::_addGradientStops(Inkscape::XML::Node *gradient, GfxShading *shading,
- _POPPLER_CONST Function *func) {
-- int type = func->getType();
-+ auto type = func->getType();
- auto space = shading->getColorSpace();
-+#if POPPLER_CHECK_VERSION(24, 3, 0)
-+ if ( type == Function::Type::Sampled || type == Function::Type::Exponential ) { // Sampled or exponential function
-+#else
- if ( type == 0 || type == 2 ) { // Sampled or exponential function
-+#endif
- GfxColor stop1, stop2;
- if (!svgGetShadingColor(shading, 0.0, &stop1) || !svgGetShadingColor(shading, 1.0, &stop2)) {
- return false;
-@@ -1185,7 +1189,11 @@ bool SvgBuilder::_addGradientStops(Inkscape::XML::Node *gradient, GfxShading *sh
- _addStopToGradient(gradient, 0.0, &stop1, space, 1.0);
- _addStopToGradient(gradient, 1.0, &stop2, space, 1.0);
- }
-+#if POPPLER_CHECK_VERSION(24, 3, 0)
-+ } else if ( type == Function::Type::Stitching ) { // Stitching
-+#else
- } else if ( type == 3 ) { // Stitching
-+#endif
- auto stitchingFunc = static_cast<_POPPLER_CONST StitchingFunction*>(func);
- const double *bounds = stitchingFunc->getBounds();
- const double *encode = stitchingFunc->getEncode();
-@@ -1200,7 +1208,11 @@ bool SvgBuilder::_addGradientStops(Inkscape::XML::Node *gradient, GfxShading *sh
- for ( int i = 0 ; i < num_funcs ; i++ ) {
- svgGetShadingColor(shading, bounds[i + 1], &color);
- // Add stops
-+#if POPPLER_CHECK_VERSION(24, 3, 0)
-+ if (stitchingFunc->getFunc(i)->getType() == Function::Type::Exponential) { // process exponential fxn
-+#else
- if (stitchingFunc->getFunc(i)->getType() == 2) { // process exponential fxn
-+#endif
- double expE = (static_cast<_POPPLER_CONST ExponentialFunction*>(stitchingFunc->getFunc(i)))->getE();
- if (expE > 1.0) {
- expE = (bounds[i + 1] - bounds[i])/expE; // approximate exponential as a single straight line at x=1
---
-2.44.0
-
diff --git a/media-gfx/inkscape/files/inkscape-1.3.2-poppler-24.05.patch b/media-gfx/inkscape/files/inkscape-1.3.2-poppler-24.05.patch
deleted file mode 100644
index bb2764032c44..000000000000
--- a/media-gfx/inkscape/files/inkscape-1.3.2-poppler-24.05.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From 96ca7a6c215aa14336b52753f56244dc8796ec43 Mon Sep 17 00:00:00 2001
-From: Heiko Becker <mail@heiko-becker.de>
-Date: Fri, 3 May 2024 14:52:00 +0200
-Subject: [PATCH] Fix build with poppler >= 24.05.0
-
-GooString::hasUnicodeMarkerLE and GooString::hasUnicodeMarker were
-rename and moved to UTF.h [1][2]
-
-[1] https://gitlab.freedesktop.org/poppler/poppler/-/commit/98fabb298b0e8eaef9193bbce68c99c85473a314
-[2] https://gitlab.freedesktop.org/poppler/poppler/-/commit/1f06dca08c32ed18c3030530d98a0e30d41dd7a2
----
- src/extension/internal/pdfinput/poppler-transition-api.h | 9 +++++++++
- src/extension/internal/pdfinput/poppler-utils.cpp | 6 ++++--
- 2 files changed, 13 insertions(+), 2 deletions(-)
-
-diff --git a/src/extension/internal/pdfinput/poppler-transition-api.h b/src/extension/internal/pdfinput/poppler-transition-api.h
-index 58aa1ec921d..481aefadf46 100644
---- a/src/extension/internal/pdfinput/poppler-transition-api.h
-+++ b/src/extension/internal/pdfinput/poppler-transition-api.h
-@@ -13,6 +13,15 @@
- #define SEEN_POPPLER_TRANSITION_API_H
-
- #include <glib/poppler-features.h>
-+#include <poppler/UTF.h>
-+
-+#if POPPLER_CHECK_VERSION(24, 5, 0)
-+#define _POPPLER_HAS_UNICODE_BOM(value) (hasUnicodeByteOrderMark(value->toStr()))
-+#define _POPPLER_HAS_UNICODE_BOMLE(value) (hasUnicodeByteOrderMarkLE(value->toStr()))
-+#else
-+#define _POPPLER_HAS_UNICODE_BOM(value) (value->hasUnicodeMarker())
-+#define _POPPLER_HAS_UNICODE_BOMLE(value) (value->hasUnicodeMarkerLE())
-+#endif
-
- #if POPPLER_CHECK_VERSION(24, 3, 0)
- #define _POPPLER_FUNCTION_TYPE_SAMPLED Function::Type::Sampled
-diff --git a/src/extension/internal/pdfinput/poppler-utils.cpp b/src/extension/internal/pdfinput/poppler-utils.cpp
-index 78d90c66c9d..c02815f64b9 100644
---- a/src/extension/internal/pdfinput/poppler-utils.cpp
-+++ b/src/extension/internal/pdfinput/poppler-utils.cpp
-@@ -12,6 +12,8 @@
-
- #include "poppler-utils.h"
-
-+#include <poppler/UTF.h>
-+
- #include "2geom/affine.h"
- #include "GfxFont.h"
- #include "GfxState.h"
-@@ -563,10 +565,10 @@ std::string getDictString(Dict *dict, const char *key)
- */
- std::string getString(const GooString *value)
- {
-- if (value->hasUnicodeMarker()) {
-+ if (_POPPLER_HAS_UNICODE_BOM(value)) {
- return g_convert(value->getCString () + 2, value->getLength () - 2,
- "UTF-8", "UTF-16BE", NULL, NULL, NULL);
-- } else if (value->hasUnicodeMarkerLE()) {
-+ } else if (_POPPLER_HAS_UNICODE_BOMLE(value)) {
- return g_convert(value->getCString () + 2, value->getLength () - 2,
- "UTF-8", "UTF-16LE", NULL, NULL, NULL);
- }
---
-GitLab
-
diff --git a/media-gfx/inkscape/inkscape-1.3.2-r2.ebuild b/media-gfx/inkscape/inkscape-1.3.2-r2.ebuild
deleted file mode 100644
index d9b60c0ac627..000000000000
--- a/media-gfx/inkscape/inkscape-1.3.2-r2.ebuild
+++ /dev/null
@@ -1,213 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit cmake flag-o-matic xdg toolchain-funcs python-single-r1
-
-MY_P="${P/_/}"
-DESCRIPTION="SVG based generic vector-drawing program"
-HOMEPAGE="https://inkscape.org/ https://gitlab.com/inkscape/inkscape/"
-
-if [[ ${PV} = 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.com/inkscape/inkscape.git"
-else
- SRC_URI="https://media.inkscape.org/dl/resources/file/${P}.tar.xz"
- KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~loong ppc ppc64 ~riscv ~sparc x86"
-fi
-
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-IUSE="cdr dia exif graphicsmagick imagemagick inkjar jpeg openmp postscript readline sourceview spell svg2 test visio wpg X"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-# Lots of test failures which need investigating, bug #871621
-RESTRICT="!test? ( test ) test"
-
-BDEPEND="
- dev-util/glib-utils
- >=sys-devel/gettext-0.17
- virtual/pkgconfig
- test? ( virtual/imagemagick-tools )
-"
-COMMON_DEPEND="${PYTHON_DEPS}
- >=app-text/poppler-0.57.0:=[cairo]
- >=dev-cpp/cairomm-1.12:0
- >=dev-cpp/glibmm-2.54.1:2
- dev-cpp/gtkmm:3.0
- >=dev-cpp/pangomm-2.40:1.4
- >=dev-libs/boehm-gc-7.1:=
- dev-libs/boost:=[stacktrace(-)]
- dev-libs/double-conversion:=
- >=dev-libs/glib-2.41
- >=dev-libs/libsigc++-2.8:2
- >=dev-libs/libxml2-2.7.4
- >=dev-libs/libxslt-1.1.25
- dev-libs/popt
- media-gfx/potrace
- media-libs/libepoxy
- media-libs/fontconfig
- media-libs/freetype:2
- media-libs/lcms:2
- media-libs/libpng:0=
- net-libs/libsoup:2.4
- sci-libs/gsl:=
- >=x11-libs/pango-1.44
- x11-libs/gtk+:3[X?]
- X? ( x11-libs/libX11 )
- $(python_gen_cond_dep '
- dev-python/appdirs[${PYTHON_USEDEP}]
- dev-python/cachecontrol[${PYTHON_USEDEP}]
- dev-python/cssselect[${PYTHON_USEDEP}]
- dev-python/filelock[${PYTHON_USEDEP}]
- dev-python/lockfile[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/pillow[jpeg?,tiff,webp,${PYTHON_USEDEP}]
- media-gfx/scour[${PYTHON_USEDEP}]
- ')
- cdr? (
- app-text/libwpg:0.3
- dev-libs/librevenge
- media-libs/libcdr
- )
- exif? ( media-libs/libexif )
- imagemagick? (
- !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
- graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
- )
- jpeg? ( media-libs/libjpeg-turbo:= )
- readline? ( sys-libs/readline:= )
- sourceview? ( x11-libs/gtksourceview:4 )
- spell? ( app-text/gspell )
- visio? (
- app-text/libwpg:0.3
- dev-libs/librevenge
- media-libs/libvisio
- )
- wpg? (
- app-text/libwpg:0.3
- dev-libs/librevenge
- )
-"
-# These only use executables provided by these packages
-# See share/extensions for more details. inkscape can tell you to
-# install these so we could of course just not depend on those and rely
-# on that.
-RDEPEND="${COMMON_DEPEND}
- $(python_gen_cond_dep '
- dev-python/numpy[${PYTHON_USEDEP}]
- ')
- dia? ( app-office/dia )
- postscript? ( app-text/ghostscript-gpl )
-"
-DEPEND="${COMMON_DEPEND}
- test? ( dev-cpp/gtest )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-libxml2-2.12.patch
- "${FILESDIR}"/${P}-poppler-24.03.patch
- "${FILESDIR}"/${P}-poppler-24.05.patch # bug 931917
- "${FILESDIR}"/${P}-cxx20.patch # bug 931917
- "${FILESDIR}"/${P}-cxx20-2.patch # bug 933216
-)
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
- python-single-r1_pkg_setup
-}
-
-src_unpack() {
- if [[ ${PV} = 9999* ]]; then
- git-r3_src_unpack
- else
- default
- fi
- [[ -d "${S}" ]] || mv -v "${WORKDIR}/${P}_202"?-??-* "${S}" || die
-}
-
-src_prepare() {
- cmake_src_prepare
- sed -i "/install.*COPYING/d" CMakeScripts/ConfigCPack.cmake || die
-}
-
-src_configure() {
- # ODR violation (https://gitlab.com/inkscape/lib2geom/-/issues/71, bug #859628)
- filter-lto
- # Aliasing unsafe (bug #310393)
- append-flags -fno-strict-aliasing
-
- local mycmakeargs=(
- # -DWITH_LPETOOL # Compile with LPE Tool and experimental LPEs enabled
- -DWITH_NLS=ON
- -DENABLE_POPPLER=ON
- -DENABLE_POPPLER_CAIRO=ON
- -DWITH_PROFILING=OFF
- -DWITH_INTERNAL_CAIRO=OFF
- -DWITH_INTERNAL_2GEOM=ON
- -DBUILD_TESTING=$(usex test)
- -DWITH_LIBCDR=$(usex cdr)
- -DWITH_IMAGE_MAGICK=$(usex imagemagick $(usex !graphicsmagick)) # requires ImageMagick 6, only IM must be enabled
- -DWITH_GRAPHICS_MAGICK=$(usex graphicsmagick $(usex imagemagick)) # both must be enabled to use GraphicsMagick
- -DWITH_GNU_READLINE=$(usex readline)
- -DWITH_GSPELL=$(usex spell)
- -DWITH_JEMALLOC=OFF
- -DENABLE_LCMS=ON
- -DWITH_OPENMP=$(usex openmp)
- -DBUILD_SHARED_LIBS=ON
- -DWITH_GSOURCEVIEW=$(usex sourceview)
- -DWITH_SVG2=$(usex svg2)
- -DWITH_LIBVISIO=$(usex visio)
- -DWITH_LIBWPG=$(usex wpg)
- -DWITH_X11=$(usex X)
- )
-
- cmake_src_configure
-}
-
-src_test() {
- CMAKE_SKIP_TESTS=(
- # render_text*: needs patched Cairo / maybe upstream changes
- # not yet in a release.
- # test_lpe/test_lpe64: precision differences b/c of new GCC?
- # cli_export-png-color-mode-gray-8_png_check_output: ditto?
- render_test-use
- render_test-glyph-y-pos
- render_text-glyphs-combining
- render_text-glyphs-vertical
- render_test-rtl-vertical
- test_lpe
- test_lpe64
- cli_export-png-color-mode-gray-8_png_check_output
- )
-
- # bug #871621
- cmake_src_compile tests
- cmake_src_test -j1
-}
-
-src_install() {
- cmake_src_install
-
- find "${ED}" -type f -name "*.la" -delete || die
- find "${ED}"/usr/share/man -type f -maxdepth 3 -name '*.bz2' -exec bzip2 -d {} \; || die
- find "${ED}"/usr/share/man -type f -maxdepth 3 -name '*.gz' -exec gzip -d {} \; || die
-
- local extdir="${ED}"/usr/share/${PN}/extensions
- if [[ -e "${extdir}" ]] && [[ -n $(find "${extdir}" -mindepth 1) ]]; then
- python_fix_shebang "${ED}"/usr/share/${PN}/extensions
- python_optimize "${ED}"/usr/share/${PN}/extensions
- fi
-
- # Empty directory causes sandbox issues, see bug #761915
- rm -r "${ED}/usr/share/inkscape/fonts" || die "Failed to remove fonts directory."
-}