summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/raptor/Manifest1
-rw-r--r--media-libs/raptor/raptor-2.0.15.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/media-libs/raptor/Manifest b/media-libs/raptor/Manifest
index 25d5a7931254..e10f3f83d5a0 100644
--- a/media-libs/raptor/Manifest
+++ b/media-libs/raptor/Manifest
@@ -1,2 +1,3 @@
DIST raptor2-2.0.14.tar.gz 1877454 SHA256 cb447b7c684cbe60f1266d622691fd20fdcf7b91f4a470c6de5fc8e8961df1b2 SHA512 399e23f2c549df8f1d709d67129d3fcf7899a8cdcdd8071c165f2b4106f397cce05fc69a6d7b176857011bf95723c0909b6510eded12f82217f89925bc1ba7c2 WHIRLPOOL dae2b80f3c0e82a9340b096ca52e89b8ccc6c849a98a7744d648f68b75dec1ff615e008a334bc7c0cc54259c9dcc07dfd6079805a0345aa7d89c9058cfd1656b
+DIST raptor2-2.0.15.tar.gz 1886657 SHA256 ada7f0ba54787b33485d090d3d2680533520cd4426d2f7fb4782dd4a6a1480ed SHA512 563dd01869eb4df8524ec12e2c0a541653874dcd834bd1eb265bc2943bb616968f624121d4688579cdce11b4f00a8ab53b7099f1a0850e256bb0a2c16ba048ee WHIRLPOOL f66c885f52731b9e4175772e64825cfb8432ddbd215cbcdf0fa5afbc55741c074fc03f89ac791636b9ef6db18ebd93291bcaa756c770426596b7189eab4c8799
DIST raptor2-2.0.9.tar.gz 1788163 SHA256 e26fb9c18e6ebf71100f434070d50196a21d592b715e361850c3b4e789b5f6ef SHA512 da4a7d28c6f8ab1d3ada7b495c0bee47adcaaf2ff3303471b986a63c22b6f190ad7e258bf0b344730cd3af24183baadefbfc6a0fd703f8466f62f9bf57dbaf2a WHIRLPOOL 80ab896bf91ce86db175141b1d609013c0bcd02601e7bf7889d2b6223744f5c91cd25fb76fc747cf30728b194cca2beae44f10c02eae10e8a386dc9da10e9544
diff --git a/media-libs/raptor/raptor-2.0.15.ebuild b/media-libs/raptor/raptor-2.0.15.ebuild
new file mode 100644
index 000000000000..00dc2d8e08ac
--- /dev/null
+++ b/media-libs/raptor/raptor-2.0.15.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit libtool
+
+MY_PN=${PN}2
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="The RDF Parser Toolkit"
+HOMEPAGE="http://librdf.org/raptor/"
+SRC_URI="http://download.librdf.org/source/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+curl debug json static-libs unicode"
+
+RDEPEND="dev-libs/libxml2
+ dev-libs/libxslt
+ curl? ( net-misc/curl )
+ json? ( dev-libs/yajl )
+ unicode? ( dev-libs/icu:= )
+ !media-libs/raptor:0"
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-3
+ >=sys-devel/flex-2.5.36
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="AUTHORS ChangeLog NEWS NOTICE README"
+
+src_prepare() {
+ default
+ elibtoolize # Keep this for ~*-fbsd
+}
+
+src_configure() {
+ # FIXME: It should be possible to use net-nntp/inn for libinn.h and -linn!
+
+ local myconf='--with-www=xml'
+ use curl && myconf='--with-www=curl'
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug) \
+ $(usex unicode "--with-icu-config=\"${EPREFIX}\"/usr/bin/icu-config" '') \
+ $(use_with json yajl) \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html \
+ ${myconf}
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ default
+ docinto html
+ dodoc {NEWS,README,RELEASE,UPGRADING}.html
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+ # https://bugs.gentoo.org/467768
+ local _rdocdir=/usr/share/doc/${PF}/html/${MY_PN}
+ [[ -d ${ED}/${_rdocdir} ]] && dosym ${_rdocdir} /usr/share/gtk-doc/html/${MY_PN}
+}