summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-doc/python-docs/Manifest1
-rw-r--r--app-doc/python-docs/python-docs-3.10.16.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-doc/python-docs/Manifest b/app-doc/python-docs/Manifest
index 2911d26a817a..a0e8bc0693d9 100644
--- a/app-doc/python-docs/Manifest
+++ b/app-doc/python-docs/Manifest
@@ -1,5 +1,6 @@
DIST python-2.7.18-docs-html.tar.bz2 4634932 BLAKE2B c48e2dede15d8186231acf65709641e0844c42e924262d6ee21a55e515aaf4d023bf394681bab780ab83998de9f409685e2d5870506810432145acc6422eff9d SHA512 db39390577ec86f13c9b6b57c01cba36fe9fd89092a773dc94f1a6a19d912759d097c4d80e765d3657b572abc731c1da9e7b4cd4c38065cd444606b906744abe
DIST python-3.10.15-docs-html.tar.bz2 7452520 BLAKE2B e9003e2a839bc934d3ba5903e1b730239e48d06686b5472660d49c51333b77ec1b0c3c48c307007e4f5d27901764d29203de475e60e97d8d8004e0b2436d168d SHA512 7056b2e9d3672b79aee26f994fd1e5168860452ec783f37cdc604dc25d3df297a9c43bda43add03a36aec85dbd1875d0c9b8eaec0fd75b809fd3811a977b69a0
+DIST python-3.10.16-docs-html.tar.bz2 7425105 BLAKE2B db25e08cd5355559a374f6ec30d2fef386b4bedfe67a55a72d4b1e5a620df8155b742a54de2d83f97901aa93f21868682dae41c88b1b3aa4c3aa2985d6e40464 SHA512 91f6f9cf1fee2bfe29404701394715bfebfd66339a4b95f530b9eef856257aaef69652908c24b150f9ac6cb5a71eea203c7bc18d94c17661e155979300f597ce
DIST python-3.11.10-docs-html.tar.bz2 7988162 BLAKE2B bc0d47ca235c8c14c4f62b554578068bf3e8460211e358cec586511be35b0aa2011075ace0602385dca2b4c2667d6bd3cb8ce4e6e6be1ed52d84b877cf3a7f6a SHA512 a14e18d3641d4379144ead7341536c781a94e9f15c9b53b2647a7c7c4cd15211963564fb2519e756b79db9234f555ede2442a678d6b4f27de6f7fb0b2993c266
DIST python-3.11.11-docs-html.tar.bz2 7983082 BLAKE2B 9e44612a894e96f2e745562672f568a65ed07df998162f7dcdcdaa550d91139750ca84d303a4eaa85358c14e60987e25f14695be9b08bd6c8d0fb581565abe8a SHA512 34f355c999a93d60226f269b51bb3499e248b316dc80413a42089a29bfbaacdc830647f68e4c0758a729424a61486564a843524905d5f0fbfdf914f346c3c474
DIST python-3.12.6-docs-html.tar.bz2 8360479 BLAKE2B 09294f5ba1ca8f53c0261e0db626aeb62ac3d66115b87feb212987ca181a2d6324a24eda97b374e6ea56e93623e487da23c50613335af4166ecba845837ae582 SHA512 5f5d37ea047810c0ae3a99585008ee02a3d4dd1b3eb573dc96eaf590c542267034fafdefd1aeb2b3e59a5b5019e4dc2562ed27d1699013c7a0609b557e5ce27c
diff --git a/app-doc/python-docs/python-docs-3.10.16.ebuild b/app-doc/python-docs/python-docs-3.10.16.ebuild
new file mode 100644
index 000000000000..59f6fa8d85d8
--- /dev/null
+++ b/app-doc/python-docs/python-docs-3.10.16.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}