summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/gumbo/gumbo-0.10.1.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/dev-libs/gumbo/gumbo-0.10.1.ebuild b/dev-libs/gumbo/gumbo-0.10.1.ebuild
index 5c7a84893a30..d046877829c1 100644
--- a/dev-libs/gumbo/gumbo-0.10.1.ebuild
+++ b/dev-libs/gumbo/gumbo-0.10.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit autotools
@@ -12,34 +12,35 @@ SRC_URI="https://github.com/google/gumbo-parser/archive/v${PV}.tar.gz -> ${P}.ta
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
IUSE="doc test"
RESTRICT="!test? ( test )"
-S="${WORKDIR}/gumbo-parser-${PV}"
+DEPEND="test? ( dev-cpp/gtest )"
+BDEPEND="doc? ( app-doc/doxygen )"
-DEPEND="test? ( dev-cpp/gtest )
- doc? ( app-doc/doxygen )"
+S="${WORKDIR}/gumbo-parser-${PV}"
src_prepare() {
+ default
eautoreconf
}
+src_configure() {
+ econf --disable-static
+}
+
src_compile() {
default
if use doc; then
doxygen || die "doxygen failed"
+ HTML_DOCS=( docs/html/. )
fi
}
src_install() {
default
+ use doc && doman docs/man/man3/*
- if use doc; then
- dohtml -r docs/html/.
- for page in docs/man/man3/* ; do
- doman ${page}
- done
- fi
+ find "${ED}" -name '*.la' -delete || die
}