summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/libpillowfight/libpillowfight-0.3.0_p20210816.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/libpillowfight/libpillowfight-0.3.0_p20210816.ebuild b/dev-python/libpillowfight/libpillowfight-0.3.0_p20210816.ebuild
index 5e1ace91926e..62e40857072e 100644
--- a/dev-python/libpillowfight/libpillowfight-0.3.0_p20210816.ebuild
+++ b/dev-python/libpillowfight/libpillowfight-0.3.0_p20210816.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -23,6 +23,7 @@ RDEPEND="dev-python/pillow[${PYTHON_USEDEP}]"
distutils_enable_tests nose
python_prepare_all() {
+ ln -s "${S}"/tests "${T}"/tests || die
sed -e "/'nose>=1.0'/d" -i setup.py || die
cat > src/pillowfight/_version.h <<- EOF || die
#define INTERNAL_PILLOWFIGHT_VERSION "$(ver_cut 1-3)"
@@ -31,8 +32,6 @@ python_prepare_all() {
}
python_test() {
- cp -r -l -n tests "${BUILD_DIR}/lib" || die
- cd "${BUILD_DIR}/lib" || die
- distutils-r1_python_test
- rm -r tests || die
+ cd "${T}" || die
+ epytest "${S}"/tests -o addopts=
}