summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pecan/Manifest1
-rw-r--r--dev-python/pecan/pecan-1.4.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pecan/Manifest b/dev-python/pecan/Manifest
index 29cda08883c2..c3f45ce4a312 100644
--- a/dev-python/pecan/Manifest
+++ b/dev-python/pecan/Manifest
@@ -1 +1,2 @@
DIST pecan-1.4.0.tar.gz 124233 BLAKE2B 42ac41d9e4aba2ad40b89d2ec742ae82a3d9f599c79d0ac5cce199b8ee50ba5e0765f02dc8812defd3e7276176d0e4dadf06b56256e9808771805df64811e9d4 SHA512 102ac8549fcb8c1f29aaf6facf1fba3dd06c454ed6262c3b0e9a009063033defbf0011b4117d854da1f4770368d3dbce1e3930daabfb0c7ee069eb2522bac7e1
+DIST pecan-1.4.1.tar.gz 124777 BLAKE2B c3af6ba06aa9e24f9e49ace8117480affd34dfdc889639ab34565325e7504d3c75f17003da09f9f67f91edc536bde95080dbc51170cccc50fde3ec1929c63958 SHA512 bd5ba47935e2d97677bcdc25ad4678ec63293e0000750fa3b39a2447be326dc7e1fd4cf77ac0519e1b7c6ecc7ba7c3e66d98443e78e647fba92383f048775c83
diff --git a/dev-python/pecan/pecan-1.4.1.ebuild b/dev-python/pecan/pecan-1.4.1.ebuild
new file mode 100644
index 000000000000..c79fc3c211ab
--- /dev/null
+++ b/dev-python/pecan/pecan-1.4.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI object-dispatching web framework, lean, fast, with few dependencies."
+HOMEPAGE="https://pypi.org/project/pecan/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/webob-1.4[${PYTHON_USEDEP}]
+ >=dev-python/mako-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/webtest-1.3.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/logutils-0.3.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest