summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/nusmv/Manifest2
-rw-r--r--sci-mathematics/nusmv/metadata.xml15
-rw-r--r--sci-mathematics/nusmv/nusmv-2.6.0.ebuild83
3 files changed, 0 insertions, 100 deletions
diff --git a/sci-mathematics/nusmv/Manifest b/sci-mathematics/nusmv/Manifest
deleted file mode 100644
index fdca8a2337a4..000000000000
--- a/sci-mathematics/nusmv/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST NuSMV-2.6.0.tar.gz 4223312 BLAKE2B 8915a3d0488a3d1d2910db7b7ad789131657c9e8f5562663333ed7b306424ded1985ffaf00b89d0edc693472c3e51003e54e6e71b853f3b28a81a5b3ae88d440 SHA512 3749e0267c2adffaa5f2f98ee925f5a774e3132277a02c549b3f4b836f8b090a44d6a14730b58251d7bb88055eb55e89f0eab7fea8714cb2f0786afd803efd0e
-DIST zchaff.64bit.2007.3.12.zip 63139 BLAKE2B d843b029f51ae2437fafb306e6e8029bc484a061d99439d1e4a195831487238753360d1ec159edefc81c1d9565e2587ca492ddb4b5b90d3025e015d3202dde8b SHA512 075d0bceede6643a880763943cba9a2fa0f6c58c47b86c0a2bbbe86a2e3925dc5b3859800d1cab0c558d727635556beb77f9efbd0f2837a768ef8d513dc2b300
diff --git a/sci-mathematics/nusmv/metadata.xml b/sci-mathematics/nusmv/metadata.xml
deleted file mode 100644
index 314da184fb2b..000000000000
--- a/sci-mathematics/nusmv/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>robbat2@gentoo.org</email>
- </maintainer>
- <maintainer type="project">
- <email>sci-mathematics@gentoo.org</email>
- <name>Gentoo Mathematics Project</name>
- </maintainer>
- <use>
- <flag name="minisat">Enable support for MiniSat</flag>
- <flag name="zchaff">Enable support for zChaff</flag>
- </use>
-</pkgmetadata>
diff --git a/sci-mathematics/nusmv/nusmv-2.6.0.ebuild b/sci-mathematics/nusmv/nusmv-2.6.0.ebuild
deleted file mode 100644
index 0163a1103bdb..000000000000
--- a/sci-mathematics/nusmv/nusmv-2.6.0.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-utils python-any-r1 toolchain-funcs
-
-MY_P="NuSMV-${PV}"
-NUSMV_A="${MY_P}.tar.gz"
-ZCHAFF_A="zchaff.64bit.2007.3.12.zip"
-
-DESCRIPTION="NuSMV: new symbolic model checker"
-HOMEPAGE="http://nusmv.fbk.eu/"
-SRC_URI="http://nusmv.fbk.eu/distrib/${NUSMV_A}
- zchaff? ( http://www.princeton.edu/~chaff/zchaff/${ZCHAFF_A} )"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="minisat doc zchaff"
-REQUIRED_USE="|| ( minisat zchaff )"
-
-SHARED_DEPEND="minisat? ( >=sci-mathematics/minisat-2.2.0_p20130925 )"
-RDEPEND="${SHARED_DEPEND}
- dev-libs/expat"
-DEPEND="${SHARED_DEPEND}
- doc? (
- virtual/latex-base
- dev-texlive/texlive-latexextra
- app-doc/doxygen
- )
- app-arch/unzip
- dev-libs/libxml2
- ${PYTHON_DEPS}"
-
-S="${WORKDIR}/${MY_P}/NuSMV"
-
-src_unpack() {
- unpack "${NUSMV_A}"
- if use zchaff; then
- cp "${DISTDIR}/${ZCHAFF_A}" "${WORKDIR}/${MY_P}/zChaff" || die
- fi
-}
-
-src_prepare() {
- sed -i -e 's/-mcpu=[^\s]*//' "${WORKDIR}/${MY_P}/cudd-2.4.1.1"/Makefile || die
- # Prevent automatic build of minisat - we are using the ebuild from portage
- sed -i -e 's/ add_subdirectory(${MINISAT_SOURCE_DIR} ${MINISAT_BUILD_DIR})//' \
- -e 's/MINISAT_LIB/MiniSat/' CMakeLists.txt || die
- sed -i -e 's/DEPENDS MINISAT_BUILD//' code/nusmv/core/sat/solvers/CMakeLists.txt || die
- # Change the "prog-man/html" rule to optional
- sed -i -e '/\s*install( .*html /s:${PROJECT_BINARY_DIR}:share/nusmv/doc OPTIONAL:' doc/prog-man/CMakeLists.txt || die
- # Change the doc destination
- sed -i -e "s:share/nusmv/doc:share/doc/${PF}:" doc/{tutorial,user-man,prog-man}/CMakeLists.txt || die
-
- # Correction for proper parallel compilation
-# sed -i -e 's/COMMAND ${MAKE}/COMMAND $(MAKE)/' "${WORKDIR}/${MY_P}/"{zchaff,MiniSat}/CMakeLists.txt || die
- default
-}
-
-src_configure() {
- local mycmakeargs=(
- -DENABLE_MINISAT=$(usex minisat)
- -DENABLE_ZCHAFF=$(usex zchaff)
- -DMINISAT_INCLUDE_DIR="${EPREFIX}"/usr/include/minisat/simp
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- local targets=( all )
- use doc && targets+=( prog-man user-man html tutorial docs )
- cmake-utils_src_compile "${targets[@]}"
-}
-
-src_install() {
- cmake-utils_src_install
- # Remove docs where they do not belong to
- rm -f "${ED%/}"/usr/share/nusmv/{LGPL-2.1,README*,NEWS} || die
-}