summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/cri-tools')
-rw-r--r--app-containers/cri-tools/Manifest3
-rw-r--r--app-containers/cri-tools/cri-tools-1.18.0.ebuild32
-rw-r--r--app-containers/cri-tools/cri-tools-1.21.0.ebuild34
-rw-r--r--app-containers/cri-tools/cri-tools-1.22.0.ebuild34
4 files changed, 0 insertions, 103 deletions
diff --git a/app-containers/cri-tools/Manifest b/app-containers/cri-tools/Manifest
index a7d71ca28c07..4b140c9a6cd4 100644
--- a/app-containers/cri-tools/Manifest
+++ b/app-containers/cri-tools/Manifest
@@ -1,4 +1 @@
-DIST cri-tools-1.18.0.tar.gz 5295512 BLAKE2B 9dda4a401b858e98aa60521d3268d8f6ff6a2c1bd2c219a0e5e9e5360fba58d41e97258c636da26ee57bbfc3286798c74107c7de92d3e3398bdf53b7d9078e94 SHA512 849b496e6d19eec29e0e56f0b37c094649311b80514f319b0c68c6519e3ddd48e1973c3d288144db998826676416644ec705b7ea0916c21898b40928ea800af1
-DIST cri-tools-1.21.0.tar.gz 6739482 BLAKE2B 365e3e9b220e63713dd21af4154b2282c20db1d19ba6b32da616c5d73957a375ab12ed2a86694abb9d90e1020be1fd89c128ed3e469d2f7524dcf42139e7df56 SHA512 a307f5526fb8b7b23a1635b168a8f3b9b9b4bd6ccb94d461dc5af2065e6d1be527dadcb1c86e04808b244d0851a4901ee78a0263f58cf673f6ca503621d5eb61
-DIST cri-tools-1.22.0.tar.gz 6821114 BLAKE2B 48bf99488cd3a65ac5ff14d8b46359f2ce7163f9810b255dfeeacea9aa2b86310d242dd174fc29490ae24a985d0cbf51bd1f4d9a752bd5828fdfae73eab2be31 SHA512 4a2751ebe0b1ed7cb739a71230272ace0cbddc516abba39c6bf07d5e2648bd60e2139935b77a5388028887915162c957f652ea05434ff7865256721d10f863df
DIST cri-tools-1.23.0.tar.gz 6823865 BLAKE2B 75d394ec1f9ccf2122476c9b845499212d668f8170ae8551913e3e057271986ab77454bdd0fa646127bfadda203fabdc57cc448dfe1e64dd7cdbedc8f5ee8cf6 SHA512 36700eaf872da14921e0b2c8fa68f91e3e0226364e29a5b8e132fbd52504e130e0bc2cce30aba21e7def576a4682f150b0b051d44b78aa694c225c10999d7155
diff --git a/app-containers/cri-tools/cri-tools-1.18.0.ebuild b/app-containers/cri-tools/cri-tools-1.18.0.ebuild
deleted file mode 100644
index 32412429f575..000000000000
--- a/app-containers/cri-tools/cri-tools-1.18.0.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit bash-completion-r1 go-module
-MY_PV="v${PV/_beta/-beta.}"
-
-DESCRIPTION="CLI and validation tools for Kubelet Container Runtime (CRI)"
-HOMEPAGE="https://github.com/kubernetes-sigs/cri-tools"
-SRC_URI="https://github.com/kubernetes-sigs/cri-tools/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="amd64"
-
-RESTRICT+=" test"
-
-src_compile() {
- emake VERSION="${MY_PV}"
- _output/crictl completion bash > ${PN}.bash || die
- _output/crictl completion zsh > ${PN}.zsh || die
-}
-
-src_install() {
- dobin _output/crictl
-
- newbashcomp ${PN}.bash ${PN}
- insinto /usr/share/zsh/site-functions
- newins ${PN}.zsh _${PN}
-
- dodoc -r docs {README,RELEASE,CHANGELOG,CONTRIBUTING}.md
-}
diff --git a/app-containers/cri-tools/cri-tools-1.21.0.ebuild b/app-containers/cri-tools/cri-tools-1.21.0.ebuild
deleted file mode 100644
index b171220105c3..000000000000
--- a/app-containers/cri-tools/cri-tools-1.21.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 go-module
-
-DESCRIPTION="CLI and validation tools for Kubelet Container Runtime (CRI)"
-HOMEPAGE="https://github.com/kubernetes-sigs/cri-tools"
-SRC_URI="https://github.com/kubernetes-sigs/cri-tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="amd64"
-
-DEPEND="dev-lang/go"
-
-RESTRICT+=" test"
-
-src_compile() {
- emake VERSION="${PV}"
- ./build/bin/crictl completion bash > "${PN}.bash" || die
- ./build/bin/crictl completion zsh > "${PN}.zsh" || die
-}
-
-src_install() {
- dobin ./build/bin/crictl
-
- newbashcomp ${PN}.bash ${PN}
- insinto /usr/share/zsh/site-functions
- newins ${PN}.zsh _${PN}
-
- dodoc -r docs {README,RELEASE,CHANGELOG,CONTRIBUTING}.md
-}
diff --git a/app-containers/cri-tools/cri-tools-1.22.0.ebuild b/app-containers/cri-tools/cri-tools-1.22.0.ebuild
deleted file mode 100644
index 7b1aff7889bf..000000000000
--- a/app-containers/cri-tools/cri-tools-1.22.0.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 go-module
-
-DESCRIPTION="CLI and validation tools for Kubelet Container Runtime (CRI)"
-HOMEPAGE="https://github.com/kubernetes-sigs/cri-tools"
-SRC_URI="https://github.com/kubernetes-sigs/cri-tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-DEPEND="dev-lang/go"
-
-RESTRICT+=" test"
-
-src_compile() {
- emake VERSION="${PV}"
- ./build/bin/crictl completion bash > "${PN}.bash" || die
- ./build/bin/crictl completion zsh > "${PN}.zsh" || die
-}
-
-src_install() {
- dobin ./build/bin/crictl
-
- newbashcomp ${PN}.bash ${PN}
- insinto /usr/share/zsh/site-functions
- newins ${PN}.zsh _${PN}
-
- dodoc -r docs {README,RELEASE,CHANGELOG,CONTRIBUTING}.md
-}