summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/coolkey')
-rw-r--r--app-crypt/coolkey/coolkey-1.1.0-r9.ebuild3
-rw-r--r--app-crypt/coolkey/files/coolkey-1.1.0-clang16.patch13
2 files changed, 15 insertions, 1 deletions
diff --git a/app-crypt/coolkey/coolkey-1.1.0-r9.ebuild b/app-crypt/coolkey/coolkey-1.1.0-r9.ebuild
index cd3d7f1e434b..d388df3391b7 100644
--- a/app-crypt/coolkey/coolkey-1.1.0-r9.ebuild
+++ b/app-crypt/coolkey/coolkey-1.1.0-r9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,6 +26,7 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${WORKDIR}/${PN}-patches"
+ "${FILESDIR}/${P}-clang16.patch"
)
pkg_setup() {
diff --git a/app-crypt/coolkey/files/coolkey-1.1.0-clang16.patch b/app-crypt/coolkey/files/coolkey-1.1.0-clang16.patch
new file mode 100644
index 000000000000..88c3e11b53e8
--- /dev/null
+++ b/app-crypt/coolkey/files/coolkey-1.1.0-clang16.patch
@@ -0,0 +1,13 @@
+Declaration taken from nss sources' lib/softoken/pkcs11i.h.
+Only needed with --enable-pk11install.
+
+https://bugs.gentoo.org/871585
+--- a/src/install/pk11install.c
++++ b/src/install/pk11install.c
+@@ -23,4 +23,6 @@
+ #include "pkcs11n.h"
+
++char **NSC_ModuleDBFunc(unsigned long function, char *parameters, void *args);
++
+ /*
+ * windows specific globing search