summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/calfw/calfw-1.3.ebuild')
-rw-r--r--app-emacs/calfw/calfw-1.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-emacs/calfw/calfw-1.3.ebuild b/app-emacs/calfw/calfw-1.3.ebuild
new file mode 100644
index 000000000000..b54fd4f67871
--- /dev/null
+++ b/app-emacs/calfw/calfw-1.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp eutils
+
+DESCRIPTION="A calendar framework for Emacs"
+HOMEPAGE="https://github.com/kiwanami/emacs-calfw"
+SRC_URI="https://github.com/kiwanami/emacs-calfw/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="howm"
+
+DEPEND="howm? ( app-emacs/howm )"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_unpack() {
+ unpack ${A}
+ mv kiwanami-emacs-calfw-* ${P} || die
+}
+
+src_prepare() {
+ use howm || rm -f calfw-howm.el
+}