summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild')
-rw-r--r--app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild b/app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild
index 0b3eb438ceeb..e199fc5b5a66 100644
--- a/app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild
+++ b/app-leechcraft/lc-musiczombie/lc-musiczombie-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI=6
inherit leechcraft
@@ -13,12 +13,17 @@ KEYWORDS=""
IUSE="debug acoustid"
DEPEND="~app-leechcraft/lc-core-${PV}
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtxml:5
acoustid? ( media-libs/chromaprint )"
RDEPEND="${DEPEND}"
src_configure() {
- local mycmakeargs="
- $(cmake-utils_use_with acoustid MUSICZOMBIE_CHROMAPRINT)
- "
+ local mycmakeargs=(
+ -DWITH_MUSICZOMBIE_CHROMAPRINT=$(usex acoustid)
+ )
cmake-utils_src_configure
}