summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/ledit')
-rw-r--r--app-misc/ledit/Manifest1
-rw-r--r--app-misc/ledit/ledit-2.04.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-misc/ledit/Manifest b/app-misc/ledit/Manifest
index 1303c66dfbe4..f20d2f02f044 100644
--- a/app-misc/ledit/Manifest
+++ b/app-misc/ledit/Manifest
@@ -1 +1,2 @@
DIST ledit-2.03.tgz 24319 BLAKE2B d0a9dfbcb21b54075b61db34035291eaf3df4a337ea9fcf24b8b163d8a45c00b667dd311f39765dc904cbae1ec34e8773dea4c7ec6753796e768a8ee4cbbb927 SHA512 94281ea31d02c046db73bed42a1835826f063ff5d1ff4c374356e37fdf6b1a018f95a6372ece0eec53193aaf2e95c234c509ac178541bfe48dbc6f223f34f661
+DIST ledit-2.04.tgz 24430 BLAKE2B 782f39606e6151307c30a665cfb6e641647fe861718ae304171db07ac82c27ee5ca9503229a27857723de98c15ac350f60be8df2e4b4fe7dc475ef2271dcf591 SHA512 56fed04fa6306b5550dc6ab4f000553d5b01eddbdeccaafad51160ba9e2c12de5faab08cb8463cad2952501c73dff0e2e214f52a30a74da20f18af153206b807
diff --git a/app-misc/ledit/ledit-2.04.ebuild b/app-misc/ledit/ledit-2.04.ebuild
new file mode 100644
index 000000000000..e987e9a7848a
--- /dev/null
+++ b/app-misc/ledit/ledit-2.04.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A line editor to be used with interactive commands"
+SRC_URI="http://pauillac.inria.fr/~ddr/ledit/distrib/src/${P}.tgz"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/ledit/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+ocamlopt"
+RESTRICT="installsources !ocamlopt? ( strip )"
+
+DEPEND=">=dev-lang/ocaml-3.09:=[ocamlopt?]
+ dev-ml/camlp5:="
+RDEPEND="${DEPEND}"
+
+# For explanation please follow the link below.
+# https://github.com/gentoo/gentoo/pull/14865#issuecomment-605697524
+QA_FLAGS_IGNORED="/usr/bin/ledit"
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 ledit.opt
+ fi
+}
+
+src_install() {
+ if use ocamlopt; then
+ newbin ledit.opt ledit
+ else
+ newbin ledit.out ledit
+ fi
+ doman ledit.1
+ dodoc CHANGES README
+}