summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/perl-support/perl-support-4.14.ebuild')
-rw-r--r--app-vim/perl-support/perl-support-4.14.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-vim/perl-support/perl-support-4.14.ebuild b/app-vim/perl-support/perl-support-4.14.ebuild
new file mode 100644
index 000000000000..638f126e6241
--- /dev/null
+++ b/app-vim/perl-support/perl-support-4.14.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit vim-plugin
+
+MY_PN="${PN}.vim"
+DESCRIPTION="vim plugin: Perl-IDE - Write and run Perl scripts using menus and hotkeys"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=556"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2 GPL-2+"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-perl/Perl-Tags
+ dev-perl/Perl-Critic"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ # Don't set tabstop and shiftwidth
+ sed -i -e '/=4/s/^/"/' ftplugin/perl.vim
+}
+
+src_install() {
+ dodoc doc/{ChangeLog,perl-hot-keys.pdf}
+ rm doc/{ChangeLog,perl-hot-keys.*,pmdesc3.text} || die
+ vim-plugin_src_install
+}