summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/cpp-taskflow/cpp-taskflow-2.6.0.ebuild')
-rw-r--r--dev-cpp/cpp-taskflow/cpp-taskflow-2.6.0.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-cpp/cpp-taskflow/cpp-taskflow-2.6.0.ebuild b/dev-cpp/cpp-taskflow/cpp-taskflow-2.6.0.ebuild
deleted file mode 100644
index aba4692adef3..000000000000
--- a/dev-cpp/cpp-taskflow/cpp-taskflow-2.6.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-utils
-
-DESCRIPTION="Modern C++ Parallel Task Programming"
-HOMEPAGE="https://cpp-taskflow.github.io"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND=""
-DEPEND=""
-
-S="${WORKDIR}/taskflow-${PV}"
-
-PATCHES=(
-)
-
-HTML_DOCS=( docs/. )
-
-src_prepare() {
- default
-
- # fix library directoy
- sed -i "s#/lib#/$(get_libdir)#g" CMakeLists.txt || die "sed failed"
-
- cmake-utils_src_prepare
-}
-
-src_configure() {
- # FIXME: enable CUDA and TESTS via use flag
- local mycmakeargs=(
- -DTF_BUILD_CUDA=OFF
- -DTF_BUILD_TESTS=OFF
- -DTF_BUILD_EXAMPLES=OFF
- )
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- if $(use doc); then
- einstalldocs
- fi
-}