summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/hyperdex/hyperdex-1.6.0-r1.ebuild')
-rw-r--r--dev-db/hyperdex/hyperdex-1.6.0-r1.ebuild23
1 files changed, 15 insertions, 8 deletions
diff --git a/dev-db/hyperdex/hyperdex-1.6.0-r1.ebuild b/dev-db/hyperdex/hyperdex-1.6.0-r1.ebuild
index 882ead1f3e2c..785eef7c7353 100644
--- a/dev-db/hyperdex/hyperdex-1.6.0-r1.ebuild
+++ b/dev-db/hyperdex/hyperdex-1.6.0-r1.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
+
EAPI=5
-# Tests fail, again
-RESTRICT="test"
+PYTHON_COMPAT=( python2_7 )
-PYTHON_COMPAT=( python2_7)
inherit eutils python-single-r1 autotools
DESCRIPTION="A searchable distributed Key-Value Store"
@@ -19,8 +18,13 @@ KEYWORDS="~amd64"
IUSE="test +python"
# need to add ruby and java useflags too
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} ) test? ( python )"
+
+# Tests fail, still
+RESTRICT="test"
-DEPEND="dev-cpp/glog
+DEPEND="
+ dev-cpp/glog
dev-cpp/sparsehash
dev-libs/cityhash
dev-libs/libpo6
@@ -30,17 +34,20 @@ DEPEND="dev-cpp/glog
dev-libs/replicant
dev-libs/libmacaroons
dev-libs/libtreadstone
- dev-libs/json-c"
+ dev-libs/json-c
+ python? ( ${PYTHON_DEPS} )"
RDEPEND="${DEPEND}"
-REQUIRED_USE="test? ( python )"
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
src_prepare() {
cp "${WORKDIR}/"*.m4 m4/
sed -i -e 's~json/json.h~json-c/json.h~' configure.ac common/datatype_document.cc daemon/index_document.cc || die "Blergh!"
eautoreconf
- use python && python-single-r1_pkg_setup
}
+
src_configure() {
econf --disable-static \
$(use_enable python python-bindings)