summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/godot/godot-4.0_alpha14.ebuild')
-rw-r--r--dev-games/godot/godot-4.0_alpha14.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/dev-games/godot/godot-4.0_alpha14.ebuild b/dev-games/godot/godot-4.0_alpha14.ebuild
index 9844ed38787e..2e22a6f9fe5a 100644
--- a/dev-games/godot/godot-4.0_alpha14.ebuild
+++ b/dev-games/godot/godot-4.0_alpha14.ebuild
@@ -244,3 +244,13 @@ src_install() {
newins misc/dist/shell/_godot.zsh-completion _${s}
dosym _${s} /usr/share/zsh/site-functions/_${s}-runner
}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ if [[ ! ${REPLACING_VERSIONS} ]] && has_version ${CATEGORY}/${PN}:3; then
+ elog
+ elog "Remember to make backups before opening any Godot <=3.x projects in Godot 4."
+ elog "Automated migration is only partial, and it would be difficult to revert."
+ fi
+}