summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/biosff')
-rw-r--r--dev-haskell/biosff/Manifest1
-rw-r--r--dev-haskell/biosff/biosff-0.3.7.1.ebuild36
-rw-r--r--dev-haskell/biosff/metadata.xml15
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-haskell/biosff/Manifest b/dev-haskell/biosff/Manifest
new file mode 100644
index 000000000000..5eaf3e813261
--- /dev/null
+++ b/dev-haskell/biosff/Manifest
@@ -0,0 +1 @@
+DIST biosff-0.3.7.1.tar.gz 26705 SHA256 982f238e056c3d65bae94c505da61e91239b624a8446ecee3b03eae258c7bad7 SHA512 ce075d734864b9a00999d5c37c824ece5ba475b583536eb842835b4a44ff56581f18ba8ddf065f2ea4416ff4f96279f6a46f5e57330a43d40164f4cabab2ab9f WHIRLPOOL 5bfb9b47df171165e9a4f03df7b3ec54c7dd07d784940409f703cb51b844449e46329164546525d9a49f8462d9bc0863d9c053b2d9d67d59e21cf99d0829d271
diff --git a/dev-haskell/biosff/biosff-0.3.7.1.ebuild b/dev-haskell/biosff/biosff-0.3.7.1.ebuild
new file mode 100644
index 000000000000..0b7b3912f571
--- /dev/null
+++ b/dev-haskell/biosff/biosff-0.3.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Library and executables for working with SFF files"
+HOMEPAGE="http://biohaskell.org/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+fclip +flower +frecover"
+
+RDEPEND="dev-haskell/binary:=[profile?]
+ >=dev-haskell/biocore-0.3:=[profile?]
+ dev-haskell/cmdargs:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag fclip fclip) \
+ $(cabal_flag flower flower) \
+ $(cabal_flag frecover frecover)
+}
diff --git a/dev-haskell/biosff/metadata.xml b/dev-haskell/biosff/metadata.xml
new file mode 100644
index 000000000000..714e2ad3539d
--- /dev/null
+++ b/dev-haskell/biosff/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ The library contains the functionality for reading and writing
+ SFF files (sequencing data from 454 and Ion Torrent). It duplicates
+ code from (and is incompatible with) the &quot;bio&quot; library.
+ </longdescription>
+ <use>
+ <flag name="fclip">Build the fclip executable.</flag>
+ <flag name="flower">Build the flower executable.</flag>
+ <flag name="frecover">Build the frecover executable.</flag>
+ </use>
+</pkgmetadata>