summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/lpeg/lpeg-1.0.4.ebuild')
-rw-r--r--dev-haskell/lpeg/lpeg-1.0.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-haskell/lpeg/lpeg-1.0.4.ebuild b/dev-haskell/lpeg/lpeg-1.0.4.ebuild
new file mode 100644
index 000000000000..1d47374670a2
--- /dev/null
+++ b/dev-haskell/lpeg/lpeg-1.0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="LPeg – Parsing Expression Grammars For Lua"
+HOMEPAGE="https://hslua.org/"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="rely-on-shared-lpeg-library"
+
+RDEPEND=">=dev-haskell/lua-2.1:=[profile?] <dev-haskell/lua-2.4:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hunit-0.9 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag rely-on-shared-lpeg-library rely-on-shared-lpeg-library)
+}