summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/janet')
-rw-r--r--dev-lang/janet/Manifest1
-rw-r--r--dev-lang/janet/janet-1.22.0.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/dev-lang/janet/Manifest b/dev-lang/janet/Manifest
index e9eba1b6d8c6..41707ad588cd 100644
--- a/dev-lang/janet/Manifest
+++ b/dev-lang/janet/Manifest
@@ -1,2 +1 @@
-DIST janet-1.22.0.tar.gz 494011 BLAKE2B 2193cf0d87421adb122e86347d47ef1a9d3141d7dedf4ba88ed3d0e97c1b22a8216e1e42a6431266c6fbb4dcee665db63839e90ec9e5530491c64a94b8b11b04 SHA512 c1e90dafa833618e0999a1a53005241b768dee66bf7e6d4cc60b7c7ce87fccba955ca2faafd4eacda320801667acbfc56087f423a4ad6abe7e97d1f08e136107
DIST janet-1.32.1.tar.gz 556827 BLAKE2B 93d7e9eefa45cfd63378f042b5efed77244ff3a32d5b17d24a06c732ec40e49d9079e325d08c8540f284a24501bd41e0fc088781acdf20bcc22694d99a2cb885 SHA512 65e00cfe9bcd66f5d640e58f965aec72f7703777e086220539a1b080d7dd44a9039247477c352d89b1e73c4f6080320bdba419bd0d20cc114985f9701e2ade2d
diff --git a/dev-lang/janet/janet-1.22.0.ebuild b/dev-lang/janet/janet-1.22.0.ebuild
deleted file mode 100644
index 7498144c0834..000000000000
--- a/dev-lang/janet/janet-1.22.0.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="A dynamic Lisp dialect and bytecode vm"
-HOMEPAGE="https://janet-lang.org https://github.com/janet-lang/janet/"
-SRC_URI="https://github.com/janet-lang/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="static-libs"
-
-MY_RELEASE="${PV::-2}"
-
-src_configure() {
- tc-export CC
-
- append-ldflags -Wl,-soname,libjanet.so.1.${MY_RELEASE}
- append-cflags -fPIC
-}
-
-src_compile() {
- # janet_build is the git hash of the commit related to the
- # current release - it defines a constant which is then shown
- # when starting janet
- local janet_build='\"'${PV}'\"'
-
- local target
- for target in '' build/janet.pc docs ; do
- einfo "Building: ${target:-main}"
- emake \
- LIBDIR="/usr/$(get_libdir)" \
- PREFIX="/usr" \
- JANET_BUILD="${janet_build}" \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- ${target}
- done
-}
-
-src_install() {
- dobin build/janet
-
- insinto /usr/include/janet
- doheader src/include/janet.h
- doheader src/conf/janetconf.h
-
- dolib.so build/libjanet.so
- dosym libjanet.so /usr/$(get_libdir)/libjanet.so.${MY_RELEASE}
- dosym libjanet.so.${MY_RELEASE} /usr/$(get_libdir)/libjanet.so.${PV}
-
- if use static-libs; then
- dolib.a build/libjanet.a
- fi
-
- doman janet.1
-
- insinto /usr/$(get_libdir)/pkgconfig/
- doins build/janet.pc
-
- dodoc -r examples
- dodoc build/doc.html
-}
-
-pkg_postinst() {
- elog "Note: jpm has been extracted to its own repository upstream."
- elog "Follow the upstream instructions on how to install it."
- elog "Enable use flag \"static-libs\" for building stand-alone executables with jpm"
-}