summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libspt/libspt-1.1-r3.ebuild')
-rw-r--r--dev-libs/libspt/libspt-1.1-r3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/libspt/libspt-1.1-r3.ebuild b/dev-libs/libspt/libspt-1.1-r3.ebuild
new file mode 100644
index 000000000000..00623ecb65c7
--- /dev/null
+++ b/dev-libs/libspt/libspt-1.1-r3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Library for handling root privilege"
+#HOMEPAGE="http://www.j10n.org/libspt/index.html"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="suid"
+RESTRICT="test"
+
+PATCHES=( "${FILESDIR}/${PN}-gentoo.patch" )
+
+src_install() {
+ default
+
+ if use suid; then
+ fperms 4755 /usr/libexec/sptagent
+ fi
+}