summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/penlight/penlight-1.9.2-r101.ebuild')
-rw-r--r--dev-lua/penlight/penlight-1.9.2-r101.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/dev-lua/penlight/penlight-1.9.2-r101.ebuild b/dev-lua/penlight/penlight-1.9.2-r101.ebuild
index 1b88d0b0c28f..8db997ae866e 100644
--- a/dev-lua/penlight/penlight-1.9.2-r101.ebuild
+++ b/dev-lua/penlight/penlight-1.9.2-r101.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -34,14 +34,21 @@ BDEPEND="
HTML_DOCS=( "docs/." )
+src_prepare() {
+ default
+
+ # This is a demo app, not a real test
+ rm tests/test-app.lua || die
+
+ # Remove test for executing a non-existent command
+ sed -e '/most-likely-nonexistent-command/d' -i tests/test-utils3.lua || die
+}
+
lua_src_test() {
- ${ELUA} run.lua || die
+ "${ELUA}" run.lua || die
}
src_test() {
- # This is a demo app, not a real test
- rm tests/test-app.lua
-
lua_foreach_impl lua_src_test
}