summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/opam/opam-1.3.1-r2.ebuild')
-rw-r--r--dev-ml/opam/opam-1.3.1-r2.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/dev-ml/opam/opam-1.3.1-r2.ebuild b/dev-ml/opam/opam-1.3.1-r2.ebuild
deleted file mode 100644
index e1d225ca5e67..000000000000
--- a/dev-ml/opam/opam-1.3.1-r2.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="A source-based package manager for OCaml"
-HOMEPAGE="http://opam.ocaml.org/"
-if [[ ${PV} != 9999 ]] ; then
- SRC_URI="https://github.com/ocaml/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-else
- inherit git-r3
- EGIT_REPO_URI="https://github.com/ocaml/opam.git"
-fi
-
-LICENSE="LGPL-3-with-linking-exception"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-lang/ocaml:=
- || ( net-misc/wget net-misc/curl )
- dev-ml/extlib:=
- dev-ml/re:=
- dev-ml/ocamlgraph:=
- dev-ml/cmdliner:=
- dev-ml/cudf:=
- >=dev-ml/dose3-5:=
- dev-ml/uutf:=
- dev-ml/jsonm:=
-"
-DEPEND="${RDEPEND}
- dev-ml/findlib
- test? ( dev-vcs/git )
-"
-
-PATCHES=(
- "${FILESDIR}"/stublibs.patch
-)
-
-src_compile() {
- emake -j1
-
- cd doc || die
- emake man
-}
-
-src_test() {
- EMAIL=foo@bar.com emake -j1 tests
-}
-
-src_install() {
- default
-
- emake \
- DESTDIR="${D}" \
- OPAMINSTALLER_FLAGS="--prefix=\"${ED}/usr\" --libdir=\"${D}/$(ocamlc -where)\"" \
- libinstall
-}