summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Crypt_CHAP/PEAR-Crypt_CHAP-1.5.0-r3.ebuild')
-rw-r--r--dev-php/PEAR-Crypt_CHAP/PEAR-Crypt_CHAP-1.5.0-r3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/PEAR-Crypt_CHAP/PEAR-Crypt_CHAP-1.5.0-r3.ebuild b/dev-php/PEAR-Crypt_CHAP/PEAR-Crypt_CHAP-1.5.0-r3.ebuild
new file mode 100644
index 000000000000..2de834bff92b
--- /dev/null
+++ b/dev-php/PEAR-Crypt_CHAP/PEAR-Crypt_CHAP-1.5.0-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit php-pear-r2
+
+DESCRIPTION="Generating CHAP packets"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+# Crypt_CHAP_MSv1 needs mcrypt which is gone in 7.2+
+RDEPEND="|| ( ( dev-php/pecl-mcrypt >=dev-lang/php-7.2:*[hash(+)] )
+ <dev-lang/php-7.2:*[crypt,hash]
+)"
+DEPEND="test? ( ${RDEPEND} dev-php/PEAR-PEAR )"
+PATCHES=( "${FILESDIR}/CHAP-1.5.0-constructor.patch" )
+
+src_install() {
+ php-pear-r2_src_install
+ insinto /usr/share/php/Crypt
+ doins CHAP.php
+}
+
+src_test() {
+ pear run-tests tests/Crypt_CHAP.phpt || die
+}