summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/APScheduler/APScheduler-3.6.3.ebuild')
-rw-r--r--dev-python/APScheduler/APScheduler-3.6.3.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/APScheduler/APScheduler-3.6.3.ebuild b/dev-python/APScheduler/APScheduler-3.6.3.ebuild
index e00b6354bb4f..9daa69e1f042 100644
--- a/dev-python/APScheduler/APScheduler-3.6.3.ebuild
+++ b/dev-python/APScheduler/APScheduler-3.6.3.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+
+PYTHON_COMPAT=( python3_{6..8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -17,7 +19,6 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/six-1.4.0[${PYTHON_USEDEP}]
>=dev-python/tzlocal-1.2[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}